FIXED: I broke my site: redirect broken, www in url, cloudflare


#1

I have two hosted domains: evolvinglibraries.com and mikekastellec.com. I tried to take advantage of the free CloudFLare offer, but quickly found that my “www” settings “Do you want the www in your URL?” would cause problems. I thought I backed out without breaking anything but apparently not. Let me start by describing how my sites worked prior to this problem, then explaining the problem will be easier.

mikekastellec.com is my home page. It’s a dead simple concrete5 page. Since concrete5 has to live in a “/home” subdirectory, I use this bit of php I found on the fourm to redirect from mikekastellec.com to mikekastellec.com/home:
index.php

[code]<?php
header(“HTTP/1.0 301”);
header(“Location: http://mikekastellec.com/home/”); /* Redirect browser */

/* Make sure that code below does not get executed when we
redirect. */
exit;
?>[/code]

That concrete5 page simply offers links to my online portfolio and my blog, which are powered by two separate wordpress installs. The portfolio lives in mikekastellec.com/portfolio, my blog is at evolvinglibraries.com. I figured all this out about a year ago and have had no problems until now.

Now, clearly I screwed something up with my www settings but I can’t figure out how to restore my stable state. Currently, mikekastellec.com shows content from evolvinglibraries.com. To see what I mean, go take a look for yourself. www.mikekastellec.com redirects to mikekastellec.com, but still shows the evolibs wordpress content, not my concrete landing page. Ditto for mikekastellec.com/home and mikekastellec.com/portfolio. evolvinglibraries.com and www.evolvinglibraries.com both work, though I had to clear my cookies first.

The current www settings for both domains:
evolvinglibraries.com: Add WWW
mikekastellec.com: Leave it alone

CloudFlare is NOT enabled for either domain.

Ideally, I’d like to “Remove WWW” from both of them, just as a personal style preference, but that’s an infinitesimal concern compared to just getting both sites working again.

If anyone can help me straighten this out, I’d deeply appreciate it. -Mike[hr]
Gah, all that typing, then I notice immediately after that somehow in my DH panel, the Web directory for mikekastellec.com was evolvinglibraries.com. Just corrected that, now I’m waiting the requisite 5-10 minutes to test.[hr]
And, yep, that’s all it took.


#2

Thanks for posting that all is well.

“Ideally, I’d like to “Remove WWW” from both of them, just as a personal style preference, but that’s an infinitesimal concern compared to just getting both sites working again.”

Just a quick note because other people may ask about the www issue. The www is only required if you’re signing up via the panel option at Dreamhost & this limitation does not apply if you signup directly for CloudFlare.