Files disappearing?


#1

Hello, I was wondering if someone could tell me how come all my files went poof? I uploaded like 8 gigs of files within the last 3 weeks and when i came to check it out today…most of the files had disappeared. I think the files disappeared around Feb.19 but i don’t know how i just “lose” 8 gigs of files out of nowhere…My website is just the index with the files listed and i know that my website isn’t advertised either cause i didn’t tell anyone and i also checked the log. Anyone know what happened? Any help would be appreciated.

Thank you


#2

The same thing happened to me twice, never found out why but DH restored from a backup and then sent me instructions on how to do it through shell access.

In your home directory there is a folder named:

.snapshot

note the dot. This folder will not show up with a normal directory listing, but it is there.

Enter the directory and then enter the weekly.0 sub-directory. Under here, you will find back-ups of your entire home directory that can be copied back over. Just for reference, here is my console when restoring the directory:

bixel: 04:51 PM# pwd
/home/username/.snapshot
bixel: 04:52 PM# cd weekly.0/domain.com/missingdirectory/
bixel: 04:52 PM# cp -Rp missingdirectory/*
~username/domain.com/missingdirectory/

And it worked great


#3

Hi, thanks for replying. I was able to find the files from the folder that u indicated…but I tried copying it over but it won’t let me, all it says that permission is denied. Bear with me please as I am still new to this.


#4

Well, I’m definately not an expert, but hopefully I can be some help.

I had trouble repeating it through shell access (I use Putty), but I just tried in my ftp and got it. I use Filezilla, so you may have to adapt this a bit depending on your program.

When I sign on (through ftp), I’m in the main directory (so I see like, mydomain.com, logs, etc…). Up at the top this is an address bar for “Remote Site” (the server), and I entered .snapshot in there (so it said /.snapshot/) and it came up that way with options for hourly, nightly and weekly.

From there just navigate into the directories and take what you need. It would probably be faster through shell access, but like I said, I had trouble recreating it there, although for whatever reason those directions were clear to me the first time and worked. :slight_smile:


#5

nm…finally somehow i was able to copy the files over. Thank you very much for the help!