Files are in the FTP site but I can't reach them!

I updated and uploaded new files into my home directory yesterday by CuteFTP.
Today, I visited my website but there was nothing in the site. no home page or any other files or folders. I thought that they might be deleted from the server so I logged in again to my FTP site by CuteFTP and found that all my files and folders are still there.
so what is the problem? why can’t visitors reach my website?

You need to put your files inside the (replacing with what ever your domain name is) directory of the FTP root.

When you browse your site, you only see files in that directory.


MP3Mystic Your personal Streaming MP3 Server
Dreamhost Hosting

I have this same issue, but I think it relates to having a “user” for ssh and a separate user for ftp. Neither user can see the other users files.

If I upload files with the FTP user, then log in by ftp using my SSH user, I can’t see the files the FTP user uploaded. However, I can see them if I ssh in. I made the mistake of uploading files using FTP then deleting the “FTP” user and now I can only see the files by ssh, not FTP.

Does anybody know which chmod command to use to make the files viewable by any user logged on by either ftp or ssh?

I agree with Jason and wheelieking that the most likely cause is your FTP and Web services being under separate users, and hence in separate folders. The quickest fix is to on Domains > Manage > Web Edit, change “All CGI to run as user” to the FTP user. I would then delete the unused user to ensure no recurrence on a new domain web service using the default settings.

And you might want to plan ahead if you’ll need multiple users’ access to the same domain. I (and Support) can find no way of implementing this with the panel, so have resorted to a poor manual method.

[quote]Does anybody know which chmod command to use
to make the files viewable by any user logged on
by either ftp or ssh?


Not Support, IME. If anyone does know any way to allow FTP access by multiple users to the same domain space, preferably by just changing the FTP user’s home directory, I’d love to know. Thanks.

That’s right. I uploaded files to the home directory instead of directory.

I appreciate your comment Jason & Chrisjj. Thanks a lot!