File system permission


#1

I have swt.dreamhosters.com mirroring steelwhitetable.org. The 2nd domain is currently hosted by someone else; I’m moving it to DreamHost, so I’ve been using http://www.swt.dreamhosters.com/ as the beta of it until I’m ready to go live on their servers.

The problem: I’ve getting 403 Forbidden on http://www.swt.dreamhosters.com/ now (I wasn’t earlier today). I was looking at the file permission in my account to ensure it was secure, and I think I messed the permissions up; HOWEVER, I was following the directions in the wiki:
http://wiki.dreamhost.com/index.php/Unix_File_Permissions_Cookbook.

$ cd ~
$ chmod 711 .
$ chmod -R u+w,a+rX example.com

I did the above, replacing example.com with steelwhitetable.org

I think the 403 started after that.

I tried:
chmod -R 755 steelwhitetable.org
and that didn’t work. Nor did 700, 711, or even 777.

I’m using this to test it:
http://www.swt.dreamhosters.com/robots.txt

QUESTIONS:

  • How to fix the above?
  • What should be the default permissions of your home directory, NOT including your domain directories?
  • What should be the permissions of your domain directories under your home directory?

I created a support ticket about it, too.

Thanks


#2

I’ve since created a new subdomain:
mudsongs.dreamhosters.com

adding a simple index.html and a robots.txt to it only; and I get a 403 on both.
http://mudsongs.dreamhosters.com/index.html

I haven’t changed any file permissions.

Odd; it’s the same problem and I haven’t changed a file permission on this new directory.


#3

Have you tried your domain name yet to see if it propagated the net yet?
I am thinking that once it is active, the temporary domain name is no longer active.
Silk


#4

Unfortunately, it has (had) nothing to do with the domain name; it fixed itself yesterday around noon. I didn’t do anything. DreamHost support replied to my ticket, saying they didn’t detect anything wrong, which was true - it was fixed by the time they checked.

It’s disturbing that this hiccup has to obvious cause or solution. I’m glad it’s fixed, though.