File permissions


#1

Currently, I am using search engine friendly urls and thus I have
renamed index.php to index and added the following lines in htaccess file:

DirectoryIndex index

ForceType application/x-httpd-php

I am running php as CGI.

If I call mkdir from index.php, it works fine. If i call it from
index I receive the following error:

Warning: mkdir(testdirec/): Permission denied in
/home/.dare/jkielisz/thehookupbook.com/testing/index on line 7

Somehow the conversion of index.php to index has changed the script’s
permissions. I have tried to change the actual permissions on index
to 777. However, that doesn’t work.

Any ideas how to fix this problem


#2

Not displaying file extensions in your URLs does not require removing them from the actual files. The following line in .htaccess will tell Apache to look for the best match to the given URL:

Options +Multiviews With this, going to http://www.thehookupbook.com/index will get you index.php.


If you want useful replies, ask smart questions.