File Locking problem

software development

#1

I’ve had my website up and running for a few months using the Pylons python framework. So far, so good.

However I made some changes, which I checked had worked, everything seemed fine. But this morning the whole site is down and I kept getting this error message:

[Sun Dec 09 00:23:08 2007] [error] [client 66.249.70.152] FastCGI: server “/home/[snip]/dispatch.fcgi” stderr: Erro
r - myghty.exception.Error: Error(IOError): [Errno 37] No locks available at /home/[snip]/lib/python2.4/site-packages/My
ghty-1.1-py2.4.egg/myghty/synchronization.py line 227

It seems that the template module Myghty uses fcntl.flock() to lock files, this has suddenly started failing. I’m not sure whether it was a change I made – I’ve rolled back to my previous working version, and it still doesn’t work – or dreamhost have changed something and locks no longer work. Or somehow I’ve screwed up some permissions for something.

Does anyone know anything about flock(), as I know it isn’t supposed to work on NFS but it has obviously been working fine up until now?

Thanks,
Dave

Dave


#2

Did you change the file permission on the folder. You may need write permission for flock to function.

Other than that, I can’t think of any solution but to contact DH support :frowning:

Save $97 (MAX Discount) with code: [color=#CC0000]97YES[/color] Sign Up NOW or More Codes Here