File Locations, etc


#1

Hi all!
I’m brand new to DH.
I moved my site from another place with the exact same folder layout. I simply copied it from one place to the other. No page changes. Have I impressed upon you how exactly the same this is? :slight_smile: The single difference is I moved from an NT server to this, Linux/Unix host.

Anyway, none of my SSI files are being parsed. Even to the point where my graphics are dead, whether I use abbreviated paths (images/xxx.jpg) or www.mysite.com/images/xxx.jpg.

I’ve been corresponding with support, but they don’t seem to get what’s going on. I don’t think they’ve looked, or they wouldn’t be sending me the responses I’ve received.

I can’t figure this out and it ain’t brain surgery. Is there some difference that I must set up when working on a different OS? I can’t imagine, but nothing else is calling SSI, images, or even some page links – which are active, correct, and exactly the same!

Thanks for your thoughts,
Christine


#2

Christine,

First, welcome to DreamHost. I’m fairly new here myself at only a few months.

One of the main differences between Windows hosting and *nix (Unix/Linux) hosting that may be running into is that *nix is case sensitive while Windows is case insensitive.

On Windows OS, ABC.htm, abc.htm, and AbC.htm are all the same file even in inclues. On *nix systems you would have 3 different files there. So if you include method uses
Images/SomeImage.jpg, but the directory on the *unix system is “images” and the file is named “someImage.jpg”, then you have 2 differences there that will cause the include to fail.

That is where I would look first. If that doesn’t turn out to be the problem, post a same of the code that is failing along with directory and file names for the actual files. You could also be running into an interpreter issue I supose, but hard to say without an example.


find/offer services free
http://www.TheHelpfulNeighbor.com
Codes:THNMax ($97) THNMaxHDD (+100%) THNMaxBW (+100% txfr) THNMaxDomains (5 free) THNBalance (20% HD&BW, 1 Domain+IP +$16)


#3

Thank you for getting back to me.

I realize case is an issue, and should have mentioned that. I am former legal environment tech support, so I type in sentence case. Always. To the point of it driving ME nuts. My pages match. I also code by hand using NoteTab Pro, so barring any individually added pieces where I could very easily typo, it’s all automatically entered when I choose preset “clips” of code.

My domain is yogadancer.com. My sub directories are few, Pattra, SSI, Scripts, Articles, images, and Asana. (Note the cases. )

As you’re probably aware, .shtml doesn’t work on a primary, index file. My first file, index.html, isn’t parsing the .css file, which is Scrpts/YogaDancer.css. In subpages, the .css file is included in an .ssi file. It’s a double whammy.

Here’s a bunch of code from an .shtml page, which worked until I moved here.
Please don’t get into how I shouldn’t use tables for formatting. I haven’t taught myself the “box” method of .css, because I just can’t visualize it. Thanks!!

Guptasana

OK. What’s the trick? I paste in code, but it only offers some of the head and the closing…!

I can give you this: ftp://arizona.dreamhost.com/yogadancer.com/index.html, but that doesn’t address the .ssi isues, only the lack of .css parsing. Of course, you can see the images aren’t pulling…

Thanks,
a confused Christine


#4

First, I think you meant to write http://yogadancer.com/index.html, not ftp://. Second, this is exactly the problem with your CSS. This line:

<link rel="stylesheet" type="text/css" ftp://72.32.70.42/httpdocs/scripts/YogaDancer.css> … makes no sense. I don’t know what 72.32.70.42 is, or why you’d want to load CSS via FTP rather than HTTP (from a different server at that), or why you don’t have an href attribute, but try correcting all this and see what happens. You probably want to do something like this:

<link rel="stylesheet" type="text/css" href="/scripts/YogaDancer.css"> But of course I can only guess at the path you need here, so double check it. Also note that the scripts directory you’re currently using is lowercase, while you just said it was capitalized. Double check.

Regarding the images, you don’t seem to have an “images” directory on this site at all.

You’ve got some serious problems here, starting with malformed HTML, up through your referencing missing directories. Start by fixing all of this. I suspect your SSI directives are also using invalid paths, so check those too. SSI works fine here.


If you want useful replies, ask smart questions.


#5

the images directory is actually Images, but you are referencing it as images.

http://www.yogadancer.com/Images/ <-- gives a directory listing
http://www.yogadancer.com/images/ <-- gives a not found error

i suggest opening up your ftp client, then going through your site page by page and tracking down files that aren’t loading. Verify that you have the same capitalization in your files as you see when browsing through ftp.

track7 - my dream-hosted site


#6

I think you’ve gotten there while I was fooling around with it.
I did mean FTP, because I haven’t been able to get into it via http. I’ve been trying different cases, different file locations, methods, etc.

My scripts directory is Scripts, so I’m not certain what you’re seeing there. (www.yogadancer.com/Scripts/YogaDancer.css) although when I type, I also capitalize YogaDancer.com. God, split hairs! I can’t believe in this day and age, they won’t resolve. Score one for NT. Ok, only one, but one nonetheless.

I certainly do have an image folder. I’m not certain where you’re looking. My transfer just completed yesterday, although I moved my site and host a week ago. It’s not like you’re even seeing my old host, because it is Scripts there, and there is an image (lower case) folder.

As I mentioned previously, this site, AS IS, worked perfectly on my previous host before they were sold. Ii do have directories, I do have matching cases, and I guess I’m even more confused.

The one odd thing I saw was that going in via dh panel ftp, there was one of my ssi files locaed on the main level. When I went in via smartFTP, there was no such file. So I can’t say you’re (nuts) seeing things incorrectly, but they don’t match what’s there.

Thanks anyway. I do appreciate your time!
Christine


#7

my images is images, not Images.
that was a built-in folder I just used or it would be capitalized.

I am going through my files one by one. I’m finding in some instances, if I go through the trouble of adding http://www.yogadancer.com/ before the image file, it’s working. I remove it? Not.

I’m still playing with my SSI, but what continues to baffle me is that this site parsed just fine. Even running tidy comes out as expected. Thankfully removing the extraneous

tags left over from my reformatting.

There’s one thing to be said for teaching yourself via online tutorials: plenty of room to make and learn from errors.

Thanks.
Christine


#8

Kill me.

I’m playing around with the file paths.
I currently have a couple of graphics in as images/Ani_Lotus.gif. They work via http, but don’t show up in the ftp viewing.
Conversely, there’s a bar at the bottom of the page in the same format that’s showing up via http, but not ftp.

I’m beginning to take this personally.
C.


#9

I see you’ve lowercased your image directory and fixed your images but your CSS line is still seriously broken:

<link rel="stylesheet" type="text/css" ftp://72.32.70.42/httpdocs/scripts/YogaDancer.css> Hostnames are not case-sensitive, only filesystem paths. “Resolve” is a term usually used with DNS, it doesn’t really mean anything in the context of case-sensitive filesystems.

If you’re seeing different things via FTP, webFTP, and HTTP, first make sure you’re logging in as the user the web site belongs to (check your hosting settings for this) and then double check that your site is correctly resolving to a Dreamhost IP address. DNS caches may explain this. It may help to use www.yogadancer.com as your FTP hostname rather than ftp.yogadancer.com. This will ensure that your FTP client and web browser are hitting the same server.

If you’re certain that your SSI directives are using correct paths, and it still isn’t working, post one here.


If you want useful replies, ask smart questions.


#10

No, I haven’t, but that’s OK.

I have been using …/Scripts/YogaDancer.css as the .css path. I tried putting in in the main directory, but that didn’t make any difference.

I’ve experimented (with many things) with upper/lower case. Unfortunately, usually I type sentence, but the domain was converted to lower when I transferred it. :frowning:

My SSI directives look like this:

When I add the http://www.yogadancer.com instead of the …/ it doesn’t make any difference.

Thanks for trying to work this out with me. I can’t help but woefully wonder why my site worked for years as is, but moving here it’s looking like I might never get it back. Of course, I’m tired and hungry, so I feel a bit defeated. [LOL]
Christine


#11

OK, I have a development.
(Changing all >< to [], )

Despite this format [!–#include file="…/SSI/Books/Pradipika.txt" --] working for years,

After digging and digging in DH’s old KB and other SSI resources online, I discovered if I changed the word file to virtual, i.e.
[!–#include virtual="…/SSI/Books/Pradipika.txt" --]
[insert drum roll] all my SSI files parse.

However, I can’t get the pages to parse or reference (whichever term works) my .css file to save my life.

Needless to say, I’ll keep working on it.

Christine