FFMpeg with H.264 Support

apps

#1

Does anyone have any experience getting FFMpeg compiled on dreamhost with H.264 support?

I’ve spent hours working my way through the process and have hit a wall.

I managed to compile yasm (necessary for libx264) into $HOME/bin and then libx264 but when I try to compile ffmpeg with the --enable-libx264 ./configure param I’m getting the following error:

BEGIN /tmp/ffmpeg-conf-11285-31070-10484.c
1 #include <x264.h>
2 int x;
END /tmp/ffmpeg-conf-11285-31070-10484.c
gcc -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112 -std=c99 -fomit-frame-pointer -E -o /tmp/ffmpeg-conf-20597-31070-10001.o /tmp/ffmpeg-conf-11285-31070-10484.c
/tmp/ffmpeg-conf-11285-31070-10484.c:1:18: x264.h: No such file or directory
ERROR: libx264 not found

Anyone have any idea?


#2

Did you compile libx264 with --enable-shared ?

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

yea,

I did find that tutorials on the subject say that it is important to run sudo ldconfig after you compile x264 which in this case I can’t do on account of the sudo…


#4

Try adding the path to .bash_profile before you compile FFmpeg.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#5

ahh see I did the ffmpeg, doing this:
http://www.netbrix.net/archives/20

however, its saying libx264 doesnt exist as well as libxvid which is what i was needing to enable… this of course is while using
–enable-gpl
and compiling it like it said in the link above…

anyone able to help me please let me know


#6

i think that ffmpeg cannot find your lib directory. normally libxvid, libx264 are in the lib directory you generated; $HOME/lib. you need to add LD_LIBRARY_PATH to .bash_profile