FFmpeg problem after the installation

apps

#1

Hi!

I know there is a lot of ffmpeg thread but i didn’t find the solution for my problem.
I followed the ffmpeg article in the dreamhost wiki and everything went fine. But when i’m trying to convert a video file i get this error message:

my .bash_profile contains this:

[quote]# ~/.bash_profile: executed by bash(1) for login shells.

umask 002
PS1=’[\h]$ '
export PATH=/home/feriboy/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games
export PATH=/home/feriboy/bin:/home/feriboy/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games
export TMPDIR=$HOME/tmp
export PATH=$HOME/bin:$PATH
export LD_LIBRARY_PATH=$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH
export CPATH=$HOME/include:/usr/local/include:$CPATH
export LIBRARY_PATH=$HOME/lib:/usr/local/lib:$LIBRARY_PATH[/quote]
Any ideas what went wrong? Should I compile my own php5 too? I just want to convert avi, mpg etc. to mp4 (x264)


#2

Remove the top 2 PATH sets, logout, then back in.

$ which ffmpeg should echo /home/feriboy/bin/ffmpeg.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

I remived the top 2 PATH line with pico, logged out logged in, which ffmpeg gives /home/feriboy/bin/ffmpeg BUT still get the same error (rror while loading shared libraries: libavdevice.so.52: cannot open shared object file: No such file or directory)


#4

Check ~/lib for libavdevice.* files (4).

Sounds like you’d best try a rebuild.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#5

Rebuild? Should I download ffmpeg and make, make install again? Sorry I’m a windows guy :smiley:
ps. I found your site a few days ago, and your php.ini installer is worked fine. Great job!


#6

I’m having this exact problem.

I compiled and installed ffmpeg locally (in ~/bin and ~/lib), but I get the error:
ffmpeg: error while loading shared libraries: libavdevice.so.52: cannot open shared object file: No such file or directory

I compiled both the latest svn version and the latest release, 0.5. Same problem.

Any ideas?


#7

i have the same problem, if i login to my website with the terminal and source .bashrc or .bash_profile it works fine. however, if i logout and login again it doesn’t work anymore. ffmpeg is not able to find the $HOME/lib directory. the solution i found is not really clean.

if somebody fixed this bug, please, let me know how to do that.[hr]
this might be helpful as well;
http://wiki.dreamhost.com/Environment_Setup


#8

I have a very simple solution: Use the ffmpeg installed in /dh/bin/ffmpeg. It’s got X264 compiled in, along with a number of other useful codecs. :slight_smile:


#9

right, it is even shipped with libvorbis and libtheora. it works fine.