FFMPEG-PHP phpize and autoconf problems

software development

#1

I’m trying to install ffmpeg so I can use PHP to convert videos from one format to the other. So far I have installed ffmpeg without any issues using the relevant Dreamhost wiki article. I then found out that ffmpeg-php had to be installed also. Fortuately there was a wiki article for this as well. However I think the article may be outdated as the wget command returns a 404.

Anyway, I downloaded ffmpeg-php from the sourceforge website and attempted to install it. I cd’d into the directory and tried to run ‘phpize’ (I don’t have a clue what this does). Well that came up with an error:

Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.

After searching on google with no luck I created a support ticket but was told they couldn’t help with thrid party scripts. So now I’m stuck. I’m not very familiar with this sort of thing which makes finding a solution near impossible. Any help greatly appreciated.

Thanks,
Rupert

Edit: I want to install ffmpeg-php as an extension


#2

Rupert, I’m stuck at the same place. Hopefully someone bails us out. I’ll let you know if I find a workaround.


#3

To do that, you will need to install a custom version of PHP (see the DH wiki - Installing PHP5).

–rlparker


#4

I have a custom install of php, and I keep getting this error when I try the phpize step of installing ffmpeg-php:

Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF environment variable is set correctly and then rerun this script.

I’ve installed autoconf and set the $PHP_AUTOCONF environment variable, but no luck.

Any thoughts?


#5

[quote]I have a custom install of php, and I keep getting this error when I try the phpize step of installing ffmpeg-php:

Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF environment variable is set correctly and then rerun this script.

I’ve installed autoconf and set the $PHP_AUTOCONF environment variable, but no luck.[/quote]
I assume you have checked the output of phpinfo() and *confirmed hat your setting of the $PHP_AUTOCONF variable actually is being set as you expected/directed?

My only thoughts at this point are that possibly that variable is somehow set incorrectly for your installation (autoconf is not where it is expected) or a permission problem that is keeping autoconf from being read.

In addition to the PHP error output, have you checked you server logs for any related/associated error messages? Sometime they can shed additional light on the nature of the problem.

Other than those possibilities, I’m not sure what to suggest. Unfortunately, custom PHP installs have a lot of potential for “borkage”,and it is really hard to tell what might have gone wrong or where the actual problem might lie. I’ve no doubt that is one of the reasons (among others!) that DH will not support such installations - it would be a huge demand on their support resources.

–rlparker


#6

rlparker, your input is helpful and much appreciated!

In bash when I type echo $PHP_AUTOCONF it shows the right path, but when I run phpinfo() from a script in a browser it doesn’t say anything about PHP_AUTOCONF.

Perhaps I’m slowly revealing my ignorance? :wink:


#7

That makes me think that your custom install is not being read, or the PHP_AUTOCONG setting is in some other way not being read.

If the phpinfo() output clearly indicates that your new install is being used, but you are not seeing that variable, possibly something is borked in your php.ini.

If the phpinfo() output does not show the your php installation is being used, then probably the .htaccess entries directing PHP files to be handled by your installation are not in proper order.

–rlparker