FFmpeg on my account


#1

Hi all!

I’m trying to install the FFmpeg (there’s a script that i’m trying to install that requires it, and it’s not the GALLERY Script). So, i’ve found this page at Wiki.Dreamhost: http://wiki.dreamhost.com/index.php/FFmpeg

I’ve followed the every step that’s shown on that page, and everything goes quite smooth, until I reach the part that says:

  1. Enter “./configure --prefix=$HOME --cross-compile”

At this point, i get this error message:

“Unable to create and execute files in /tmp. Set the TMPDIR environment
variable to another directory.
Sanity test failed.
If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
ffmpeg-devel@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file “config.err” produced by configure as this will help
solving the problem.”

My knowledge on SSH are very restrict, actually this is the 1st time i’m “messing around” with it… so i have no clue at all, of how can I fix this… mayve some other more experienced user wouldn’t mind, to kindly help me on this task?

I know that there’s avaliable a compiled version of FFmpeg already, made by FLORIDAVE (another customer from Dreamhost), I tried to upload that file into my space, but it doesn’t seems to work… since it’s compiled to use with the Gallery 2 Script… so i guess, that one would be useless in my case.

Many thanks in advance.


#2

mkdir ~/tmp/
chmod 755 ~/tmp/

TMPDIR="~/tmp" ./configure --prefix=$HOME --cross-compile


#3

Nicely done. But isn’t that last line supposed to be two lines?

mkdir ~/tmp/
chmod 755 ~/tmp/

TMPDIR="~/tmp"

./configure --prefix=$HOME --cross-compile

-Scott


#4

I am still getting the same error … these are the steps that I followed

  1. Login to SSH as the owner account of your directory
  2. If ~/bin doesn’t already exist, enter “mkdir bin” to create it
  3. Enter “chmod 775 bin” to set the correct permissions for the bin directory
  4. If ~/lib doesn’t already exist, enter “mkdir lib” to create it
  5. Enter “chmod 775 lib” to set the correct permissions for the bin directory
  6. Enter “svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg” to download the ffmpeg program source
  7. Enter “cd ffmpeg” to navigate to the source directory
  8. mkdir ~/tmp/
  9. chmod 755 ~/tmp/
    10.TMPDIR="~/tmp"
    11.Enter “./configure --prefix=$HOME --cross-compile”

And this is the part where I get the same error … can you please help … maybe I am putting some steps in the wrong spot

Thanks!


#5

You’re creating the tmp folder in the wrong place. When you prefix the location with “~/” that means under my home directory. You’re down in ffmpeg though. You would need to “mkdir ~/ffmpeg/tmp” or just “mkdir tmp” while you’re in that folder.

http://benconley.net
http://teamshocker.com


#6

Shouldn’t setting the TMPDIR environment variable override this? The first error from way back said it didn’t have proper access to /tmp (in root). Now that the user has created ~/tmp and set TMPDIR, this problem should go away.

Though at this point it may be worth a try, but it sounds like he’s still getting the /tmp error.

Hey, which shell is this person using? Just type ‘env’ to see. Maybe the environment settings aren’t sticking.

-Scott


#7

I am using puTTy to install ffmpeg … but I really dont understand much about how it works. I typed in env and got the following

TERM-xterm
SHELL=/bin/bash
SSH-CLIENT=MY IP ADDRESS
and then a bunch more information … which line is needed

Thanks for all the help! I have been trying for about a week and still cant get it to work … I just dont know what I am doing wrong


#8

I am getting the exact same errors on this issue. I’m using puTTy also.

Here is what I did:

Login to SSH as the owner account of your directory

If ~/bin doesn’t already exist, enter “mkdir bin” to create it

Enter “chmod 775 bin” to set the correct permissions for the bin directory

If ~/lib doesn’t already exist, enter “mkdir lib” to create it

Enter “chmod 775 lib” to set the correct permissions for the bin directory

Enter “svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg” to download the ffmpeg program source

Enter “cd ffmpeg” to navigate to the source directory

So far so good … BUT I also get the /tmp error in the next step:

./configure --prefix=$HOME --cross-compile --enable-shared

Error Received is:

‘Unable to create and execute files in /tmp. Set the TMPDIR environment
variable to another directory and make sure that /tmp is not mounted
noexec.
Sanity test failed.
If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
ffmpeg-devel@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file “config.err” produced by configure as this will help
solving the problem.’

I have tried ‘mkdir tmp’ & ‘chmod 775 tmp’ once inside the ffmpeg dir and running the ‘./configure …’ command again, but the same error still occurrs.

Please will someone make some simple instructions that work (or better even … update the wiki page instructions)

Kind regards,

-ds-


#9

got the same problem !


#10

I had the same problem. By setting the TMPDIR enviornment variable I was able to get past this problem. Just try:

export TMPDIR=~/tmp

That assumes you’ve created the tmp dir in your home directory like one of the previous posts suggested.


#11

yaa , i got it to work

http://www.catmindeye.com/media/2006/07/installing_ffmpeg_on_dreamhost.html

is where i found my answer

thanks all , and hope this url helps anyone else that need help with this