Ffmpeg LAME libfaac libfaad

apps

#1

Hello,

I have compiled FFmpeg with no problem using the instructions on the wiki : http://wiki.dreamhost.com/index.php/FFmpeg

But I would like to know if there is a tutorial to compile FFmpeg with the LAME, libfaac and libfaad library on a dreamhost user account.

I’m new to compilation, and after the LAME installation (./configure --prefix=$HOME) I can’t compile FFmpeg properly using the --enable-mp3lame (can’t find the library I supose).

So any hints wil be very helpfull !

thanks,

Bertrand


#2

Hi Bertrand,

I had a difficult time setting this up myself but I think I finally got a working version that can puke out an flv with audio using ffmpeg and lame. Let me preface the fact that i’m pretty clueless when it comes to compiling. I searched for a couple days, came up with bits and pieces and after quite a few compiles, actually I lost count, I got one that worked for me.

You’ve obviously got ffmpeg installed:
http://wiki.dreamhost.com/index.php/FFmpeg

clean the make for ffmpeg (make clean), and delete all the files that were created, or just wipe everything and start fresh.

I created a folder on root that would house everything for both lame and ffmpeg called “fmpeg”. Hopefully this won’t make things confusing.

(replace username where necessary)
install lame to ‘fmpeg’ folder:
i just uploaded the tar and extracted it to a folder called “lame”.
cd to “lame” folder
./configure --prefix=/home/username/fmpeg --disable-shared
make
make install

cd to ffmpeg folder and install to ‘fmpeg’ folder and configure with lame:
./configure --enable-mp3lame --prefix=/home/username/fmpeg --extra-cflags=-I/home/username/fmpeg/include --extra-ldflags=-L/home/username/fmpeg/lib
make
make install

from what I gather cflags and ldflags are pointers to the lame include and library files that are needed.

also i get an initial “permission denied” when creating the config file no matter what the settings are, and when running the make it’s strife with warning errors but i’m guessing those are normal?

upload a quicktime or something and test…

/home/username/fmpeg/bin/ffmpeg -i titleofvideo.mov -ab 56 -ar 22050 -b 500 -r 15 -s 320x240 test.flv

outside of the above I won’t be much help unfortunately, maybe someone else can explain what all the flags mean.

if it works for you we should probably add it to the wiki or something.

Hope this helps some,
Dunc


#3

Thank goodness. I was searching for like six hours (no lie) trying to figure out how to do this. I had done everything right it seemed,and yet the ffmpeg wouldn’t compile properly, giving me problems with the lamemp3. It was installed and all, but I suppose I just needed to add the extra links in the configuration. Now it works like a charm. Thanks alot. I’ve no doubt as flvs are becoming increasingly popular, this information will be a great deal helpful to many people. Thank you :smiley:


#4

I’m having a more elemental problem than that. I’ve downloaded lame, but when I attempt to run ./configure, I get a permission denied error. Does anyone know why this might be happening?

Thanks,
Brian