Ffmpeg issues converting wmv files



Today I tried using ffmpeg to convert a ‘.wmv’ file (a slideshow video) to FLV. The wmv was created using Windows photo story 3. The result was a video that seemed to be missing all of the image transitions (fading and zooming). My existing ffmpeg conversion process has worked fine for me for years for other video filetypes. I am wondering if this could be caused by ffmpeg being out of date (running 0.7, also wondering whether a newer version is installed on other servers where I could potentially request a move - I’m avoiding a manual install as I’ve seen that others have had install issues and my capabilities at the command line are not that advanced), or if I could improve the result by changing the command arguments.

I am using the command as follows:
ffmpeg -y -i infile.wmv -sameq -acodec libmp3lame -ar 22050 -f flv outfile.flv

Thanks in advance for any assistance


0.7 is a reasonably recent version of ffmpeg — it’s more likely that there’s something odd about the slideshow video that’s making it convert incorrectly. Is there any chance you can post a link to the original for us to have a look at?


[edit: removed link]


The slideshow video is an an unusual format (WVP2, a format used primarily by Photo Story) which ffmpeg doesn’t fully support. You will need to convert it to another format before ffmpeg can process it properly.


OK, thank you for the informative answer.


There’s a truly unreal amount of spam showing up on this thread (I just deleted something around TWO HUNDRED spam posts). Please email me if you’d like me to reopen it for further comments.