Ffmpeg for gallery 2

apps

#1

any one install ffmpeg on dreamhost server and how ?

any help would be appreciated im using gallery2 and want to have thumbnails of my movies


#2

[quote]any one install ffmpeg on dreamhost server and how ?

any help would be appreciated im using gallery2 and want to have thumbnails of my movies[/quote]
Do not cross post.


Simon Jessey
Keystone Websites | si-blog


#3

[quote]Jeez, Simon, could you possibly be more rude and demanding, and less helpful? –
It’s obviously not obvious to some newcomers.[/quote]
I’ve never come across a forum, message board, bulletin board, or mailing list where cross posting isn’t frowned upon in the strongest possible terms. I kept my post brief and informative, because I didn’t want to waste my time getting into a netiquette discussion.

You obviously have a personal dislike for me, Bob, though I fail to see why. Why not just ignore my messages? I sometimes wonder that you only post these types of replies to (a) get on my nerves or (b) to get your referral code some more exposure.


Simon Jessey
Keystone Websites | si-blog


#4

If memory serves, I just grabbed it from cvs (according to their website) via:
cvs -z9 -d:pserver:anonymous@mplayerhq.hu:/cvsroot/ffmpeg co ffmpeg

Then compiled and dropped it in ~/bin, then configured gallery2.

No magic really. Worked out of the box.


#5

hey thanks for the post ok here is where im at maybe you can help me.

first i ftp the zip file of ffmpeg to a dir called ffmpeg

then i unziped it connecting with putty ssh

then from the folder ffmpeg which is in the root of my website here is what i did

./configure
make
make install

then looking in my ffmpeg dir i have a compiled ffmpeg.

my question is how do i get it over to my local/usr/bin directory

what commands and from where can i copy or move the compiled ffmpeg to my local/usr/bin folder???

please help anyone


#6

I hate to bring up old posts but here’s an easy way to do this.

set the install path in the configure command

./configure -prefix=/home/username

when you run make install it will put the files in /home/username/bin/


#7

[quote]If memory serves, I just grabbed it from cvs (according to their website) via:
cvs -z9 -d:pserver:anonymous@mplayerhq.hu:/cvsroot/ffmpeg co ffmpeg

Then compiled and dropped it in ~/bin, then configured gallery2.

No magic really. Worked out of the box.[/quote]
how do you compile through SSH?


#8

Above should read:

./configure --prefix=/home/username

when you run make install it should put the files in /home/username/bin/

Ive just tried this but I got permission denied messages for creating bin and lib in my username directory. I created these two folders with write permission and tried make install again, this time I got: “install: cannot change
permissions of `/home/username/bin’: Operation not permitted”

anyone know what I can do?


#9

You’re substituting your real username for “username”, right? (Just double-checking.)

Also, make sure the permissions for your new ~/bin directory are 775.

Last, if the installer is trying to change the permissions on ~/bin, you may have to dig through the makefile to see what it’s trying to do. You may have to enable group write for your home directory during the install.

Same for your new ~/lib directory if you see similar errors for it.

-B…


#10

Yes, I was replacing ‘username’.

Ok figured it out, had to be logged in as the owner of my install directory.

Summary–> To install ffmpeg:
-Login to SSH as the owner account of your directory.
-enter: “cvs -z9 -d:pserver:anonymous@mplayerhq.hu:/cvsroot/ffmpeg co ffmpeg” this will copy the ffmpeg CVS files into the directory ffmpeg
-enter “cd ffmpeg” navigates to that directory
-enter “./configure --prefix=/home/username” replacing username with your username
-enter “make”
-enter "make install"
DONE!


#11

This is going to sound noobish…but I followed your instructions and everything went smoothly. But now I can’t figure out what directory to make the script search. =X

I’ve tried everything I could think of, but it won’t detect ffmpeg in any of the directories I set. And I’ve tried just about everything.

Thanks!


#12

I’m not sure what you mean by script but ffmpeg will be located in:

/home/USERNAME/bin/ffmpeg

replace USERNAME with yours.


#13

Thanks for the reply, I’m pretty sure it’s just zOOm gallery not detecting it properly. I tried that and almost everything else and it won’t find it. Thanks again.