Ffmpeg + amr



Today I was trying to install ‘ffmpeg + amr’ from todays’ SVN.
Dreamhost wiki information is all wrong. The ‘./configure’ line you give doesn’t work - configure complains that
none of those options exist.

% ./configure --prefix=$HOME --enable-amr_nb --enable-amr_nb-fixed --enable-amr_wb
Unknown option “–enable-amr_nb”.
See ./configure --help for available options.

So with --help’s help I guessed that this might work:

./configure --enable-libamr_nb --enable-libamr_wb --enable-libmp3lame

it fails with:

ERROR: libamrnb not found
If you think configure made a mistake, make sure you are using the
version from SVN. If the latest version fails, report the problem to
ffmpeg-devel at mplayerhq.hu mailing list or IRC #ffmpeg on
Include the log file “config.err” produced by configure as this will
solving the problem.

ok, let’s try once more
let’s install libamrnb and libamrwb from source code and when configuring ffmpeg show where to find files:

Get the ffmpeg sources and get amr

svn co svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg
wget http://ftp.penguin.cz/pub/users/utx/amr/amrnb-
wget http://ftp.penguin.cz/pub/users/utx/amr/amrwb-

Configure amrnb and amrwb:

./configure --prefix=$HOME

make && make install

This time ffmpeg configuring works:

./configure --prefix=/home/HOMEDIR/opt/ffmpeg-svn --enable-libamr-nb --extra-cflags=-I/home/HOMEDIR/opt/libamrnb/include --extra-ldflags=-L/home/HOMEDIR/opt/libamrnb/lib --enable-libamr-wb --extra-cflags=-I/home/HOMEDIR/opt/libamrwb/include --extra-ldflags=-L/home/HOMEDIR/opt/libamrwb/lib

make && sudo make install

But now when trying to run ffmpeg i get error:

/home/HOMEDIR/opt/ffmpeg/bin/ffmpeg: error while loading shared libraries: libamrnb.so.2: cannot open shared object file: No such file or directory

I started all from scratch 5 times, using different directories and different tutorials.
What i am doing wrong? Please help me set up latest ffmpeg with full amr codec support.