Fatal Error

wordpress

#1

I’m new to the forum, however I am not new to WordPress. I am receiving the following error when attempting to login to my wp control panel.

Fatal error: Allowed memory size of 94371840 bytes exhausted

The person hosting my files is telling me that the problem is probably plugin memory exhaustion, so I’m curious if there is actually a separate memory allowance for plugins? Isn’t the entire site housed under one php memory allocation (of apparently 90M)? Wouldn’t memory need to be increased in the wp-config.php file?

This issue has persisted for nearly a week with little help from person hosting the site for my client. I’ve asked for ftp login credentials to delete plugins myself if that’s the case, but I’m not getting that either.

Is there anything I can do?

Thanks


#2

It’s possible to add a little more memory for that “user” via a prprc file. That does not expand/extend the total memory limits of the account however. (assumption: that we are talking about shared hosting) See: https://help.dreamhost.com/hc/en-us/articles/214893937-How-do-I-increase-the-PHP-memory-limit-

There is no separate memory space for plugins. I belive the message you’re being given is “your plugin have exhausted the memory”.

“The person hosting your files” may not want to up the limit for your WP installation, as it has other effects on their dreamhost account.


#3

Thank you LakeRat, that’s what I assumed the problem was: that this person is limiting the memory of the sites (it’s happened more than once, the previous “solution” was to delete a plugin I was using). I am not consuming an exorbitant amount of space with the few plugins I’ve installed and these issues have only shown up within the last month or so. I have never had this sort of problem with any other projects I’ve worked on; every plugin I use, I test on my server first so I know how it behaves and what to expect.

Also, I currently have no access to ftp to affect the files, however I do have dh control panel login, but I can’t do anything useful with limited permissions, correct?


#4

Actually 90MB is the default. They don’t appear to have imposed a smaller limit than the default.

this isn’t iOS, disk space and memory needed are two entirely different things.

Did the problem start with a WP or plugin update installation?

Testing on “your” server isn’t the same thing as real-time performance. For starters your servers environment isn’t exactly the same. For second, your probably not generating the same “load” during your testing as that’s very difficult to do “offline”. (random visits by users and pseudo-users or bots)

Can’t tell you because I don’t know what kind of “limited permissions” you have in the panel. If someone is granting limited permissions to a panel account there is MANY MANY check boxes.


#5

Keep in mind that not all plugins use the same amount of memory. Some are very lightweight, and others are memory hogs. (“Related Posts” type plugins take up an enormous amount of memory as the size of your database increases.) So it’s possible for someone to have twenty installed plugins and use less memory than someone using only five.


#6

Thanks LakeRat, I get it. My knowledge is limited. However, that’s why I’m here. I’m trying to get a better idea of the problem so that I can find a solution. I’m at a loss.

The bottom line, I’ve never encountered this issue before with sites that were hosted through other hosting companies. The same error message has occurred on two separate sites, I want to know not only how to fix it, but also to avoid the problem in the future. I’ve researched extensively online, the only answers I’ve found are to increase memory in wp-config.php, however I don’t have access to that file.


#7

You can try deactivating one plugin at a time until you find the one that seems to be causing the problem. If that doesn’t solve the issue, it may not be plugin related. (Themes can also use a lot of memory.)


#8

kjodie: Yes thank you, I opened up a support ticket and all is good. I appreciate both of your feedback and assistance.


#9

The basic solution is that you need to put something infront of your Varnish instance that supports SSL!