Fastcgi and wordpress

wordpress

#1

Hi. This is my first post here :smiley:

My issue is about enabling fastcgi module in wordpress according this wiki ling:
http://wiki.dreamhost.com/index.php/PHP_FastCGI
it doesn’t work (error 500). I have done it a lot of times but i think it is about that module or the .htaccess

Can anyone help me??

The script php5-wrapper.fcgi (executable) is:

#!/bin/bash
export PHP_FCGI_CHILDREN=3
exec /dh/cgi-system/php5.cgi

And the .htaccess is:

Options ExecCGI
AddHandler fastcgi-script fcg fcgi fpl
AddHandler php5-fastcgi .php
Action php5-fastcgi /php5-wrapper.fcgi

BEGIN WordPress

RewriteEngine On RewriteBase /blog/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /blog/index.php [L] # END WordPress

(between Options and ExecCGI
there is a (plus)

Thanks, do you know what is wrong? I want to enable it to have a lower CPU consumption


#2

That line with Options +ExecCGI AddHandler fastcgi-script fcg fcgi fpl
needs to be split:

Options +ExecCGI AddHandler fastcgi-script fcg fcgi fpl …all the rest

That should fix it.

-Scott


#3

Sorry. It is mistake i have had here. It is splitted in the .htaccess


#4

I have WordPress running with PHP5 FastCGI and it’s not giving me any errors. My files look like yours. But I found this discussion:
http://markjaquith.wordpress.com/2006/10/28/some-wordpress-205-users-reporting-server-500-error/

-Scott


#5

Oh yeah, and if you want to lower CPU consumption, which gets you a faster site, enable WP-Cache in your WP Admin Plugins panel.

-Scott


#6

No. It makes slower my site. I have just disabled wp-cache.
I prefer using fast-cgi for a better performance


#7

Thanks. But, i use Wordpress 2.2 and if possible it hurt my DB. I am going to see the content of this plugin to watch what it does.


#8

I have checked the php plugin and it is ok. I am going to try it tomorrow. Thanks


#9

I’m also running WordPress 2.2 (from the One-Click install).

Uh, in Manage Domains from the DreamHost control panel, do you have FastCGI Support turned on? It’s not on by default.

-Scott


#10

This must be a issue in fast-cgi module in my hosting :@
Thanks everybody


#11

Or maybe it’s this glitch:
http://www.dreamhoststatus.com/2007/06/18/500-internal-server-errors/

-Scott