Failed to Write to Disk Error

wordpress

#1

I am receiving a “Failed to Write to Disk Error” in wordpress. This seems to be only on large file sizes. I increased my maximum upload size to 100m using php.ini by inserting:

memory_limit = 256M
upload_max_filesize = 100M
max_execution_time = 900
max_input_time = 900
post_max_size = 100M
file_uploads = On

My upload_tmp_dir is set to no value which means Dreamhost has control over it and they said it is empty. My permissions are set to : “777” on my uploads folder.

What am I missing. I have to be able to upload a file that is around 40mb.


#2

What kind of file is this? Image or video or…?


#3

Never set…

[quote=“wahhadesign, post:1, topic:59542”] My permissions are set to : “777” on my uploads folder.
[/quote]

anyone that wants to can hack your account.


#4

Directory permissions should be 700 min / 755 max. If anyone suggests altering a directory to 777 under any circumstance then you should immediately stop listening to any advice they give with respect to web programming.

The simple answer has always been “do not rely on PHP to handle file uploading”. File type is irrelevant; file size and method is. If you are dealing with large files regularly, implement an FTP or CGI uploading alternative.


#5

777 is fine if you’re testing and debugging, but 755 is really better.

FlieTYPE is not irrelevant. WP throws some fun errors when you use certain file types. It normally tells you that you’re not allowed to upload that type, but sometimes it balks and throws the generic error.

File Size, similarly, should throw a decent error about … well file size :wink: You should be able to handle 40mb with that setup.

What flavor of PHP are you running?


#6

I’m running into the same error on my WP install for any files over 30MB. I’ve bumped up to the 128MB max of the /tmp partition, but still get the error. Any file <30MB are ok.

WordPress 3.9.1
/tmp is 128MB and has 126MB free
/wp-content/uploads and all sub-dir are 755
~/php/5.3/phprc reads:
; {{{ The following lines were automatically added by DreamHost
extension=xcache.so
; }}} That’s all from DreamHost

upload_max_filesize = 100M
post_max_size = 100M
max_execution_time = 500
max_input_time = 500
file_uploads = On
session.save_path = /tmp
upload_tmp_dir = /tmp


Thanks for any help!! I’m at the end of my knowledge on troubleshooting this issue.