Failed to install OCaml


#1

HI,
I want to enable my mediawiki’s math function function, so I downloaded the Source distribution for Windows and Unix system: ocaml-3.09.3.tar.gz .

Then I accorded to the instructions on http://wiki.dreamhost.com/index.php/Unison. However, when I unzip the package to /ocaml folder, and type the:

“./configure -prefix $HOME/sw && make world && make bootstrap && make opt && make install”

in SSH, it returned:

-bash: ./configure: Permission denied

What can I do?

Thanks!


#2

In INSTALL, Prerequisites, it says:

“If you do not have write access to /tmp, you should set the environment variable TMPDIR to the name of some other temporary directory.”

Do you have write access to /tmp? Trying: touch /tmp/junkfile.txt will tell.


$1 for me << [color=#00CC00]SE7ENOF9[/color] | [color=#CC0000]SE7ENOF97[/color] >> All for you


#3

HI,
I tired touch /tmp/junkfile.txt

but nothing displayed…
thanks!

is that because my user name dosen’t have the right?


#4

[quote]but nothing displayed…

[/quote]

So it worked. Good. You have permission to write in /tmp.

I suspect 2 problems. (1) Something went wrong in your download, untar; or (2) Directory you expanded to causes permission problem; or (3) other :slight_smile:

Did you even get message:
“Configuring for a i686-pc-linux-gnu …” ?
If not, then script did not go far at all.

How did you get tar.gz onto server and expand it? Where did you expand it? FWIW, I put in /home/user/ocaml and it worked ok.

Can you edit configure file, put set -x on 2nd line (original blank), re-run ./configure… command; see where it stops?


$1 for me << [color=#00CC00]SE7ENOF9[/color] | [color=#CC0000]SE7ENOF97[/color] >> All for you