Errors reinstalling PHP


#1

I’ve been trying to get my custom PHP reinstalled since the Great Debian Upgrade of Sept 2nd to no avail.

I’ve run the two versions found on the wiki
(I sure with there was a discussion section on each wiki page)

In both cases, this is what I’m running into. All is well until it gets down to the last two things to install - the c-client section and the php section.

Problem #1:
In the c-client section, I get the following error, followed by the return of the [tethys]$ prompt:

[color=#CC0000]cp: cannot stat `c-client/c-client.a’: No such file or directory[/color]
So I look in the source/imap-2004g/c-client folder and sure enough, no “c-client.a” file. There is a “c-client.h” file though.

So, I removed that entire c-client section from the install and ran it again. Now it gets down to the section where it configures the php itself.

Problem #2:
It kicks out the following error and dies:

[color=#CC0000]Configuring extensions
checking whether to enable LIBXML support… yes
checking libxml2 install dir… /home/mycjreports/php5
checking for xml2-config path… /home/mycjreports/php5/bin/xml2-config
checking whether libxml build works… yes
checking for OpenSSL support… yes
checking for Kerberos support… no
checking for DSA_get_default_method in -lssl… no
checking for pkg-config… /usr/bin/pkg-config
configure: error: Cannot find OpenSSL’s <evp.h>
[/color]

So, I tried to find an openssl on /usr or even /etc through shell and can’t see it. I’ve tried to locate “evp.h” but all of the directories deny permission.

I’m so frustrated with this and why it isn’t working. Again, I’ve done both the standard script on the top and the two-script alternative on the bottom and both jump ship in the same place. Any help would be so greatly appreciated.

I don’t know specifically what c-client does or if I need it. I do need openssl enabled with some of the things my site does…used to do.

Thanks in advance.

Jim


#2

Just in case someone else is dealing with this, I thought I’d share a response to my question about openssl: