Error when install php5

software development

#1

I’ve try many time with many install script i found on wiki.dreamhost.com but alway i’ve got an error

/home/xxxxxx/source/php-5.2.6/ext/date/lib/parse_date.c -o ext/date/lib/parse_date.lo
gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See URL:http://gcc.gnu.org/bugs.html for instructions.
For Debian GNU/Linux specific bug reporting instructions, see
URL:file:///usr/share/doc/gcc-4.1/README.Bugs.

make: *** [ext/date/lib/parse_date.lo] Error 1

I’ve try install php-5.2.5, 5.2.6, 5.3alpha … but just a same error.

Some body have any ideas to help me, please?
Thank so much.


Sorry about my language :stuck_out_tongue:


#2

If you’re getting the same Kill message with “many install scripts” then it might be either a memory issue or possibly a rabid Watchdog.

Maximum Cash Discount on any plan with MAXCASH


#3

What is mean “many install scripts” ? I’ve used the script on http://wiki.dreamhost.com/Installing_PHP5 :

  • Main PHP 5 install script
  • Alternative PHP 5 install scripts
  • Another Alternative PHP 5 install script

I’ve got same ideas from php.net :

[25 Jun 2007 4:10pm UTC] sniper@php.net
Just to rule out all other issues here, try using this configure line:

rm config.cache ; ./configure --disable-all --disable-cgi

make clean

make

[25 Jun 2007 4:30pm UTC] sniper@php.net
You could also try passing configure the --disable-inline-optimization

Just got a same error :frowning:

I need edit the upload_max_size and ionCube on my site, but when following step 6 on http://wiki.dreamhost.com/Advanced_PHP_configuration
it say :
-bash: ./php-update.sh: /bin/bash^M: bad interpreter: No such file or directory


#4

rm -rf {~/source,~/php5,~/dist}
mkdir -p ~/ioncube
mkdir -p ~/domain.com/cgi-bin
cp -f /etc/php5/php.ini ~/domain.com/cgi-bin/php.ini
cp -f /dh/cgi-system/php5.cgi ~/domain.com/cgi-bin/php.cgi
chmod 711 ~/domain.com/cgi-bin
chmod 700 ~/domain.com/cgi-bin/php.cgi
chmod 600 ~/domain.com/cgi-bin/php.ini

Then edit domain.com/.htaccess:

AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

Upload the correct loader into $HOME/ioncube folder and edit your php.ini

Maximum Cash Discount on any plan with MAXCASH


#5

i’ve done all steps you say, but when add
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi
in to .htaccess my site can’t run.

Here is my phpinfo http://mrdevi.net/info.php (without edit anythings in php.ini)

And here is phpinfo with edited php.ini to load ionCube http://up.mrdevi.net/info.php

But, both my site isn’t work, unless remove
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi
on htaccess

U can go to http://mrdevi.net and http://up.mrdevi.net/setup/install.php to see the error

Thank for support me


#6

Make sure you edit your htaccess file with a true text editor (I use my ftp client to edit files)

Put your ioncube info right at the top your ini file:

[PHP]
zend_extension="/home/username/path/to/ioncube_loader_lin_5.2.so"

I’m familiar with XtraUpload and know that it uses an irregular mix of proper (<?php) and short (<?) tags, so you may need to change or add a line in your php.ini:

short_open_tag = On

Maximum Cash Discount on any plan with MAXCASH