Error on Server


#1

I want to make Ruby on Rail application direct on server
for that …I use

rails -d mysql library …to create library application
it shows warning…
/home/copychops/.gems/bin/rails:17:Warning: require_gem is obsolete. Use gem instead.

after that whn i run nxt command…
ruby script/generate model Book
/usr/lib/ruby/1.8/yaml.rb:133:in syntax error on line 20, col 1: ‘usern’ (ArgumentError)

Please clarify this what are these error and y cann’t i run the application easily.