Error after importing a database to phpbb

apps

#1

Hello,
After importing my database through phpmyadmin, i am getting this error

phpBB : Critical Error

Error creating new session

DEBUG MODE

SQL Error : 1054 Unknown column ‘session_admin’ in ‘field list’

INSERT INTO phpbb_sessions (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in, session_admin) VALUES (‘412594b78c69a48b8f3b8d7e9bbb49f0’, -1, 1155767897, 1155767897, ‘cf65e374’, 0, 0, 0)

Line : 187
File : sessions.php

I really do not know much about php, i was a little bit overwhelmed in the edit area, as i really did not know what to look for, is there an easy fix or some documentation someone can point me to?

Thanks in advance


#2

The error message is saying there is something wrong with the database, not PHP. Your probably trying to import database information from a different version of phpBB than you are using now. Since the database structure is different between these two versions, you probably need to follow an “upgrade” process.

You haven’t said what version you are using now and before.

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#3

thanks for the response.

Im not so sure what version the old database was exported from, but I am using the latest version that one-click installed for me v2.0.21
(i just browsed the .sql file and saw this – phpMyAdmin SQL Dump
– version 2.6.4-pl3
http://www.phpmyadmin.net

– Host:
– Generation Time: Apr 24, 2006 at 08:03 AM
– Server version: 4.1.14
– PHP Version: 4.4.

Ill check out some upgrade docs…thanks again


#4

i was able to update the database to the latest one, now the error i am getting is

phpBB : Critical Error

Could not open orange101 template config file

DEBUG MODE

Line : 503
File : functions.php

This is line 503 in the functions.php

message_die(CRITICAL_ERROR, “Could not open $template_name template config file”, ‘’, LINE, FILE);

so it seems that I dont have that theme, and it has been taken down by the phpbb admins, as it used code without the authors consent. I tried to get into the admin page to change it to default, but no luck. Anyone have an idea where I can revert back to the default style?


#5

I was able to find a fix on the phpbb boards for this. Thanks again for pointing me in the right direction