Enabling CGI in Revolution

software development


I use a cross-platform programming language called Revolution from Runtime Revolution, Ltd. They make their engine available in a form that allows us to create CGI applications that run in that engine. I’ve done this many times on an OS X server.

I uploaded the x86 version of the Linux rendition of the Revolution engine to my space and gave it 755 permissions. Then I uploaded to simple test CGi scripts that both reference revolution on their first line like this:

#!revolution -ui

(I’ve tried with and without the -ui switch, which is documented to suppress an attempt on the part of the revolution engine to invoke its UI.)

The error I see is:

revolution: /lib/libc.so.6: version `GLIBC_2.3’ not found (required by revolution)

So it seems to me that: (1) I am indeed invoking the revolution engine as a CGI engine; and (2) it is unable to find a library it needs.

Question, then, is whether this library exists on the server, whether I should be able to access it assuming it does, or whether perhaps I need to put revolution somewhere else?


Have your tried running revolution from the command line to see if it even works then?

One of the first tests in trouble shooting is command line testing. That way you can make off #1 from your list and point all doubt to #2 (or what ever else may happen).