Enable Apache Mod_Rewrite


#1

iam not sure if this is the right right category for my problem.
i installed smf 1.1.3 and installed the seo4smf mod. but its not working. someone told me that maybe my apache mod_rewrite is disabled. how will i know if it is really disabled?


#2

Well, mod_rewrite is enabled here by default.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#3

if the mod_rewrite is enabled how come my installation of seo4smf is not working i installed it for the 4th time and iam tired of uploading again and again. this option says that

This changes the format of URLs a little so search engines will like them better. They will look like index.php/topic,1.html.

This feature will not work on your server.

Does anyone here installed the seo4smf successfully?


#4

Mod_rewite works fine on DreamHost (many use it!) but there is likely to be a problem with seo4smf, according to Google.

It appears to be related to DreamHost’s use of PHP-CGI and the way seo4smf is coded.

Here a a couple of Forum threads that address this, and provide solutions (isn’t Google great?):

http://www.webmasterstalks.com/seo-4-smf/htaccess-question-t1031.0.html

http://www.webmasterstalks.com/seo-4-smf/i-have-a-big-bug-t837.0.html;msg4679#msg4679

–rlparker