Email spam tags have changed..heads up

I had to redo some of my message filtering today because the spam tags have changed. Just in case anyone else has an issue…

That’s not the only thing they changed… they’re also auto-filtering some of your mail into “Promotional” and “Social” folders, without any notice to the users that they’re doing this. If you’re retrieving only the main inbox via POP, you won’t even see that there are other messages (not just spam) that you’re missing. You have to log in to webmail (which they’ve changed from SquirrelMail to a new AtMail program that many have been criticizing on this forum) to see the other folders (probably an IMAP client would work as well).

It absolutely blows my mind how bad they screwed this up. I am not paying for private servers and virtual private servers for tons of clients to have dreamhost automatically inject folders into my email accounts and decide how my email gets sorted by filtering my email. It’s fine if they want to filter junk mail (they’ve completely screwed that up as well since both my old junk rules AND their new junk rules are filtering my spam putting email in multiple folders and they’ve completely removed the old settings or the ability to turn them off) but DO NOT decide for me what emails should be forwarded to any other folder than my inbox. I have missed A LOT of mail in the last few days because all of that email is no longer going to my inbox. I’ve tried deleting the new folders but they keep coming back and there’s no way to either turn off those additional filters or adjust their settings.

Chat support just tells me to fill out a support ticket and like typical dreamhost, those support tickets are being ignored. Horrible email service and horrible support.

I’ve been with dreamhost for 16+ years but it’s time to move all my clients to a hosting provider who cares about their customers and the tons of business those customers bring to them.

YES! Shocking to see that they didn’t realize the impact these automated filters would have on those of us running solo businesses who RELY on email. I’m exhausted from working and also trying to undo all the extra work this email transition has imposed on me. Of course, I had to first figure out why I wasn’t getting critical email that I was waiting for. Sheesh!

Very, very, bad move on DH part here.

I’m using MacOS (Sierra) Mail for IMAP. I just configured it today, but I’m not seeing a Promotional or Social folder. That sounds a lot like what Gmail is doing.

You don’t see those folders because they finally removed the filters. Also, the folders only showed up after you would receive an email for the first time that they thought belonged in either a promotion or social folder… and yes, they are copying google’s gmail and I hate gmail which is why I don’t use it.

After a few support tickets I FINALLY got a response. They said they had sent this email to me but I never received it - which proved my point that their filtering system was crap. Here’s their response:


We realize that a consistent email experience is a hugely important part
of your service with DreamHost.

Recently we rolled out two features to all DreamHost customers - a new
webmail client, Atmail, and a behind-the-scenes spam filtering and
message categorization service from Vade Secure.

We’ve received some feedback from DreamHost users letting us know that
automatic filtering of promotional and social mail is not something
that’s important to them. In response to that feedback, we have disabled
our newly-added incoming email categorization feature.

Please note that, despite this change, spam filtering will continue to

You can continue to whitelist and blacklist certain email addresses and
domains from your account control panel using the steps at

We are looking at several options to get the power of this advanced email
filtering technology into your hands in a way that is non-disruptive to
your workflow, and your feedback is key to helping us do that.

Thanks very much for your patience, and thanks for telling us how to make
email work best for you!

Good…it’s gone. I turned it off at Gmail as well.