Email setup through Gmail now requiring SMTP?


#1

So, I’ve been using Gmail for the email on all of my domains. In the past, the way I set this up (in Gmail) went like this:

Once this was done, Gmail would send an email to my Dreamhost email account with a verification link. Upon clicking on the link for verification, I could then send and receive email at my Gmail account (but using my domain email address). Then I would go back into Dreamhost and set the email address to forward to my gmail account. Done. Easy peasy.

Recently, Gmail changed the way this works and now I’m at a complete loss. After I uncheck the “use as alias” button and click “next step”, the process asks for me to sign in to the SMTP server. I’ve tried every combination of usernames and passwords I can think of, but I keep getting this error:

[quote]Authentication failed. Please check your username/password.
[Server response: DNS Error: Address resolution of smtp.twilightsleep.net. failed: Domain name not found code(0) ][/quote]

I have no idea what to do. Please help?


#2

Can ANYONE help me with this??


#3

Go to the web page for http://www.google.com/mail and configure it to accept “Access for less secure apps” to TRUE. You can find the page in the web page -> settings (upper right corner) -> Accounts and Import -> Other Google Account Settings.

This removes the requirement that the host be “registered” with gmail. DreamHost’s SMTP is not able to do that. Once you do that, then you can send SMTP mail via gmail from DreamHost.


#4

Ok, tried that but I’m still having the same issue. The problem is that I don’t know know what to enter when it asks for the SMTP username and password. It never used to ask for this info but I’ve tried putting in every username and password on my Dreamhost account and it won’t accept any of them???

Someone please help me figure this out…


#5

Hi ohthatshannon,

Your error mentions ‘smtp.twilightsleep.net’ failed — the correct SMTP server name/record would be mail.twilightsleep.net rather than smtp.twilightsleep.net, for incoming and outgoing. I believe your username should be your full email address and your password that you set up previously.

Please let us know if it works after changing your server settings!

Thank you!


#6

Ok, I changed the server name but I’m still getting the authentication failed error. It says check username/password and, again, I’ve tried every username and password I have.


#7

Hi ohthatshannon,

Did you try entering your full email address as the username? I had the same issue, but found out here that you have to enter your full address: name@domain.com.


#8

Ohthatshannon, I realize this thread is old, but wanted to update it for others. The advice above was all correct for me, but in addition to changing the default servername setting from “stmp” to “mail,” I also had to change the default PORT setting to 465.
That did it for me–though I did still get the confirmation e-mail from GMail.


#9

I cannot find this option, are you sure that it’s still possible ? Thank you.

Finally found it with a google search:

https://www.google.com/settings/security/lesssecureapps