Email Form error

wordpress

#1

Recently installed WP on my site, and cannot get any email form installed to work. I am aware the “from” email needs to be based from my server, which it is.

I have Contact Form 7 and a form with my theme and both fail.

I have installed Configure SMTP with the following settings:
SMTP host = localhost
SMTP port = 587
Sender e-mail = aaron@mydomain.com

I get the following error from Configure SMTP upon test:
SMTP Error: The following recipients failed: aaron@mydomain.com
SMTP server error: 5.7.1 aron@mydomain.com

note: the second line is not a misprint, but is the msg received. the correct email should be “aaron@” not “aron@” - I’ve done a quick search in my DB and find no instance of “aron@”.

thank you for any help on this.

aaron


#2

If you mean http://wordpress.org/extend/plugins/configure-smtp/ then you actually don’t need to configure it at all. Yes, I know how weird that is to say! Undo the settings, and just have the plugin be there, but blank.

The ‘sender’ email is the one you fill in on the front end of the form, though, in CF7. Check if you have a typo there?


#3

Thank you for your response. I reset the plugin but left it active. Testing still returns the error from above. I’ve also 2x the email in the contact form and in my general user settings.

http://www.aarontheboy.com/contact-form-7/
attempting returns error:
“Failed to send your message. Please try later or contact the administrator by another method.”

original form provided by theme:
http://www.aarontheboy.com/contact-original-form/

  • returns success message though no message is ever received.

any other ideas/suggestions? thanks.


#4

For CF7, how did you set the ‘from’ to be you?


#5

It was set to the standard settings:
To: aaron@mydomain.com
From: [your-name] <[your-email]>

I know all email needs to be from my domain, though I though SMTP Config overrides any settings.

I changed it to
To: aaron@mydomain.com
From: aaron@mydomain.com

and I still receive an error message for the variable: #Sender’s message was failed to send

The other form provides a success message, but never gets received.

Again, my Config SMTP test fails upon testing, so I don’t think it’s the form.


#6

Just to make sure, it looks like this?

CloudApp

#7

correct. screenshot of my setup enclosed:
http://postimage.org/image/ip0h09m23/
[hr]
Thank you for testing - I just received your test email. I’ve just tried testing both forms and neither has been received.


#8

I don’t see anything wrong with your settings. At this point, I think we need to open a ticket so someone can poke into the mail server (which I don’t have access to) and make sure everything’s set up correctly. This could be an error in config somewhere.

You may be asked to let a DreamHost tech log into your WP site. If you’re worried about us knowing passwords, you may want to make a dhadmin user for that. Then when we’re done, you can delete it :slight_smile:


#9

sounds good. thank you for investigating into this.