Email Client Configuration - SMTP Problems


#1

I’m trying to use an email client to use an email address tied to a domain hosted on Dreamhost. I’ve tried two clients (Thunderbird and Geary) on Ubuntu 14.04. After manually setting the settings Geary gives me a message “SMTP Connection Error”. Thunderbird manual configuration says “Thunderbird failed to find the settings for your email account”. The settings I’m using in Thunderbird are:

your name: my name
email address: aname@mydomain.com
password: mypassword

Incoming: IMAP : mail.mydomain.com : 993 : SSL/TLS : Autodetect
Outgoing: SMTP : mail.mydomain.com : 587 : SSL/TLS : Autodetect

I have also tried the same settings with “Normal Password” and with “Autodetect” for all ports and protocols.

I’m not sure if I’m configuring something wrong or if there’s something about the server I’m not understanding?

Thanks for any help!

p.s. - Does Dreamhost support STARTTLS? Should I be using that? I see conflicting info on the web.


#2

I’ve never set up Thunderbird and Geary on Ubuntu 14.04 so all I can give you is generic info.

You’re correctly using the fully qualified email address as user, and the ports are correct.

Using mail.example.com will cause a certificate mismatch error. Usually not a show stopper but it can be avoided by changing the hostname for the mailserver, see http://wiki.dreamhost.com/Certificate_Domain_Mismatch_Error#Direct_server

SMTP does have to be configured to use credentials. I’ve have used the checkbox “use the same credentials as incomming” (or however it’s worded) and had that both work and NOT work. What always works tho is to just manually specify the credentials again (they are they same as incoming) for SMTP.

I’m not sure exactly what protocol is in play, I set up iDevices most frequently anymore and it simply has a “Use SSL” switch that seems to auto detect the rest. I agree the dreamhost wiki has conflicting info.


#3

Thanks LakeRat! I will read the page, see if it gets things sorted, and report back!

UPDATE: That doesn’t seem to have changed anything. Any other suggestions would be greatly appreciated! Thanks!


#4

Imagine my surprise when I opened up my outlook settings to see if I could help further and found encryption set to ‘none’. First I tried “Auto”, failed. then “SSL”, failed. then “TLS” back to ‘none’ and now that is failing too. “None” used to work obviously. I haven’t touched my outlook settings in years.

Since it usually takes 24 hours for dreamhost support to reply, I’ll find some time later to force an IP change and see if the problem clears up for “none”. My suspicion is that in my attempts to SSL/TLS working I triggered something on the server that is making it ignore my IP. I logged into webmail and that access works, and my phone (which is already using SSL) is still is able to access the account.

How about telling us what settings you found that worked?


#5

Sorry it took me so long to respond! Yeah, that’s what’s got me puzzled. If I don’t want to use encryption it seems to work, so it must be some aspect of that that’s causing the problem. (Sorry that my question broke your email, although I guess it’s good that you know that your encryption was off!) Were you able to get it going?


#6

I’ve been out of town, and lost all my thread with unread messages in this forum. In short, I gave up on the mail problem. I don’t actually use dreamhost for anything serious mail wise.