Emacs 23


#1

Hi!

Any reason why the emacs installed on the web servers is at version 21? If not, then I would greatly appreciate an update to a more recent version (23.x).

Many thanks!

ristan


#2

I don’t speak for the management but these guys believe in stability.
I think they are running Debian Etch, (or possibly Woody!) and that is the default.

Regards.


#3

Whaaaaat? Er, we’re not quite that behind. :stuck_out_tongue:

No, we’re running Lenny on most of our machines, on which Emacs 22.3 is the available version.


#4

$ ssh my.private,server apt-cache policy emacs
emacs:
Installed: 21.4a+1-3etch1
Candidate: 21.4a+1-3etch1


#5

[code]$ apt-cache policy emacs
emacs:
Installed: (none)
Candidate: 22.2+2-5
Version table:
23.1+1-4~bpo50+1 0
200 http://mirror.newdream.net lenny-backports/main Packages
22.2+2-5 0
500 http://mirror.newdream.net lenny/main Packages

$ which emacs
/usr/bin/emacs

$ emacs --version
GNU Emacs 21.4.1

[/code]

I just bought the VPS upgrade, can I simply install emacs through apt? Will that old emacs install (which apt doesn’t seem to know about) complain?