Elgg installation - htaccess rewrite problem

apps

#1

Hello,

I installed Elgg yesterday on my site in a subfolder. The path is:

www.mysite.com/elgg/html

I don’t like the long URL so I wanted to redirect it to just www.mysite.com

I’ve been editing the .htaccess file for a day now and can’t get this to work. I’m a newbie so I have no clue what I’m doing / supposed to do.

Can someone help me?

Here’s what my .htaccess file looks like. Can someone tell me what to change to make this redirect thing work?

Elgg htaccess directives

Copyright Curverider Ltd 2008

License http://www.gnu.org/licenses/old-licenses/gpl-2.0.html GNU Public License version 2

Link http://elgg.org/

<IfModule !mod_rewrite.c>

ugly ugly hack to detect missing mod_rewrite

RedirectMatch must be to an absolute destination, so forces 500 error…

ErrorDocument 500 "Elgg error: Apache does not have mod_rewrite loaded. Please check your Apache setup."
RedirectMatch 302 .* index.php

<Files “htaccess-dist”>
order allow,deny
deny from all

Don’t listing directory

Options -Indexes

Follow symbolic links

Options +FollowSymLinks

Default handler

DirectoryIndex index.php

php 5, apache 1 and 2

# default memory limit to 64Mb php_value memory_limit 64M # to make sure register global is off php_value register_globals 0 # max post size to 8Mb php_value post_max_size 8388608 # upload size limit to 5Mb php_value upload_max_filesize 5242880 # hide errors, enable only if debug enabled php_value display_errors 0

RewriteEngine On

If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line

containing the path from your site root to elgg’s root. e.g. If your site is

http://example.com/ and Elgg is in http://example.com/sites/elgg/, you might need

RewriteBase /elgg/html/

here, only without the # in front.

If you’re not running Elgg in a subdirectory on your site, but still getting lots

of 404 errors beyond the front page, you could instead try:

RewriteBase /

RewriteRule ^action/([A-Za-z_-/]+)$ engine/handlers/action_handler.php?action=$1
RewriteRule ^actions/([A-Za-z_-/]+)$ engine/handlers/action_handler.php?action=$1

RewriteRule ^export/([A-Za-z]+)/([0-9]+)$ services/export/handler.php?view=$1&guid=$2
RewriteRule ^export/([A-Za-z]+)/([0-9]+)/$ services/export/handler.php?view=$1&guid=$2
RewriteRule ^export/([A-Za-z]+)/([0-9]+)/([A-Za-z]+)/([A-Za-z0-9_]+)/$ services/export/handler.php?view=$1&guid=$2&type=$3&idname=$4

RewriteRule ^_css/css.css$ _css/css.php

RewriteRule ^pg/([A-Za-z_-]+)/(.*)$ engine/handlers/pagehandler.php?handler=$1&page=$2
RewriteRule ^pg/([A-Za-z_-]+)$ engine/handlers/pagehandler.php?handler=$1

RewriteRule xml-rpc.php engine/handlers/xml-rpc_handler.php
RewriteRule mt/mt-xmlrpc.cgi engine/handlers/xml-rpc_handler.php

Also, I’ve been researching this on the internet and some people say that I have to change something in the http.conf file to make it work but I have no idea where to find this file?

Please help!


#2

please?? anyone? it’s really urgent.


#3

[quote]I don’t like the long URL so I wanted to redirect it to just www.mysite.com

I’ve been editing the .htaccess file for a day now and can’t get this to work. I’m a newbie so I have no clue what I’m doing / supposed to do.[/quote]
In the web panel go to Domans -> Manage Domains

Change the “web directory” (called the document root) to /home/username/elgg/html

If that doesn’t work change it back to what it was before and re-install elgg but don’t install it into a subdirectory.

:cool: openvein.org -//-