Elgg and "register_globals"

apps

#1

For some reason, I’m getting an error when I try running Elgg… it says that register_globals is on and that it’s a major security issue. It told me to edit the .htaccess file so I added

to it. However, it’s continuing to tell me that register_globals is on. How do I get it to work?

Thanks


#2

You won’t be able to turn register_globals off via .htaccess, though you can do so by installing you own PHP or using DH’s installed PHP with you own custom php.ini (both options are discussed thoroughly in many threads on these forums and in the DH wiki.

Additionally, you can always elect to use DH pre-installed PHP5, which has register_globals already set to “off”. To do this, just go to the Control Panel -> Domains -> Manage Domains screen , click the “Edit” link under the “Web Hosting” column for your domain, modify the settings on the resultant screen to select PHP5 for your domain, and submit the form (save your changes).

When the change “takes” (after a few minutes), you r domain will be running PHP5 with register globals “off”.

–rlparker


#3

Oh that’s cool. I changed it to PHP5. Thanks. I’ll tell you if it worked