Eight DAYS of downtime?


#1

One of my websites, http://whydaddydrinks.net, has been down for eight DAYS now. It is hosted on the Quicksilver server, along with my other sites. I have opened several tickets regarding this, the most recent of which is #5165824, today at 3pm, with no response yet.

I understand that servers fail, I understand that sometimes downtime is unavoidable. Eight DAYS of downtime, however, is simply inexcusable and I need this fixed. The only thing I have done (which Support tried to blame me as being the problem) was change the user account that the domain was running under. The user account that it was running under was broken in some way where I couldn’t log on as that user via FTP or SSH. I moved the site to run under my main account, and now I can see files missing and permissions incorrect.

I hope that someone can address this as soon as possible.


#2

Just got an automated message that my support request was moved to a different queue. Since this is at least the third request to receive this response, I’m starting to think “queue”=“trash”.

Very disappointed in Dreamhost, a company whose praises I’ve been singing for several years now.


#3

Did you notice that the error your blog give has:

Whydaddydrinks.net/wp-blog-header.php with your domain name starting with a capital W

I am pretty sure that should be a small letter w


#4
  1. I’m pretty sure that domain names are case-insensitive. It’s the part after the / that is case-sensitive.

  2. Everything worked prior to the Quicksilver failure and subsequent restore. The only thing I’ve changed is the user account under which whydaddydrinks.net runs.

  3. Now that whydaddydrinks.net runs under a user account that is able to login, I can see that there are files missing and incorrect permissions. The wp-content folder is owned by root:root and some folders/files are still owned by the original user. I can also see that many files are missing.

Thank you, Ronthai, but I’m pretty sure that that’s not my problem, nor is it something that I can fix without Dreamhost Support.


#5

Have you opened a support ticket? To get help from dreamhost support you must do this, they will not work on your problem from a forum post. The people helping you here are just other customers like yourself.


#6

LakeRat, I have opened SEVERAL support tickets, many of which have gone unanswered after several days. I wasn’t sure if DH support read these forums or not, but they don’t seem to be reading my support tickets either.


#7

The message I see on your site would seem to indicate a coding error, not something the host would be responsible for.

This is what I get:

Warning: require_once(/home/snoopyh42/Whydaddydrinks.net/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/snoopyh42/Whydaddydrinks.net/wp-blog-header.php on line 12

Fatal error: require_once() [function.require]: Failed opening required ‘/home/snoopyh42/Whydaddydrinks.net/wp-load.php’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /home/snoopyh42/Whydaddydrinks.net/wp-blog-header.php on line 12

I don’t speak PHP, but this sounds like something is wrong with the WP configuration.


#8

domain names are case insensitive, but the Linux file system is not. So when you include /home/user/Mydomain.com, then you had better be sure that the directory is really named Mydomain.com and not mydomain.com

edit i mistyped insensitive in the original reply as sensitive. The second sentence should make it clear that it was a typo. Thanks to andrewf for pointing it out.


#9

bobocat, that’s incorrect. The Linux file system is case sensitive as well.