Easyhost.cgi file upload size problem


#1

I am using easyhost.cgi to allow a number of people to upload files to my site. A file of about 11 MB works fine. If the filesize gets larger I always get an internal server error: The server encountered an internal error or misconfiguration and was unable to complete your request. Maybe someone knows a solution to my problem?
Many thanks in advance.


#2

You may want to check your settings. It could be due to the upload file size limit.

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#3

I cann’t find any upload file size limit. There is however a limit method: hard: diskquota: 150 MB.


#4

try to use phpinfo() function to check the upload size limit. If the problem is about the upload file size limit, you may want to follow wiki to change it. http://wiki.dreamhost.com/index.php/PHP.ini

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#5

You might check your error logs to see exactly what error is reported when you get the Internal Server Error as that may give a clue to what is happening.

Unfortunately, Nathan’s response to your post regarding phpinfo() will not help you here, as easyhost is written in perl, not PHP, and the php limits are irrelevant to it’s operation.

Lastly, Cyberscript.net support pages do have this very question, but the answer is “blank” - it looks like they may be having trouble with their database. You might want to ask Cyberscript about this issue. You did not indicate whether yuo are using the “free” or “commercial” version, and I do not know if that makes any difference for the problem you are having.

–rlparker


#6

If you are talking bout your DH “quotas” here, you probably need to check the actually limits set in the easyhost.cgi program itself.

From admin.cgi, check "configure, and check the last section entitled “scripts”, where you will find another “space limit”, stated in “KB”, Make sure this is high enough.

–rlparker


#7

There seems to be an “Out of memory!” error.

I know that phpinfo will not help me. Because of the limitations of php I use this script. And I found the “blank” supportpage. Which is exactly my problem. Couldn’t find anything on usenet either.

And I do use the free version.


#8

I am talking about the easyhost quotas.

If I log in as admin I can’t find what you are describing. On the Control Panel–>System Configuration there is a tab Service with a section General Limits. This can be set to either hard or soft. Soft doesn’t work properly so I changed it to hard with a Disk Quota of 150 MB.
And there is a tab Configuration with sections Paths and General Limits (username and password lengths). I can’t find anything about scripts.
Or am I missing something here?


#9

Ouch! I don’t know of any easy “fix” for that, and I’m sure it would involve manipulating the upload code (which is a bit problematic, as the script in question is not licensed appropriately for such modification).

I’m also thinking the “absence” of that “support” page at their website might indicate this is a “known” problem. :wink:

I also realize now that you are using version 2.0 of the program (I originally looked at version 1.0 when preparing my first responses to you - I apologize for the “bum steer” on the configuration screen). From looking at the demo on the website, I suspect the whole limit files-size issue might be one of the differences between the “free” and $299 version, as a “limit file size” setting is available on the demo of the paid version.

I’m sorry, I don’t have any other suggestion at this point, except to see if you have any luck contacting cyberscript.net for a possible solution or workaround (which I would not be surprised if they are unwilling to discuss regarding the “free” version).

–rlparker


#10

No, you are not missing anything…I apologize for looking at an “old” version of the script initially - the screens I described were in version 1.0 (see my preceding response).

–rlparker


#11

I posted an email to Cyberscript.net. Maybe I get an answer. But because of the fact that I use the free version I don’t have many hopes.

Thanks anyway for all the responses.


#12

No problem regarding the responses; though I realize I have not been of much help in getting the problem resolved. :frowning: .

If you hear back form Cyberscript, I’d appreciate you posting back with what you learned as that information may well be helpful to others. :wink:

–rlparker


#13

I certainly will.