Drupal


#1

I’m trying to install Drupal (http://www.drupal.org/) CMS onto my site, but I’m having a problem. The installation instructions say:

Your PHP must have the following settings:
session.save_handler user
In addition, we recommend the following settings:
session.cache_limiter none
These values are set in php.ini and can be overwritten in a .htaccess file

But when I try to do that it doesn’t work. I beleive my .htaccess file is correct, but the values of those variables aren’t being changed for some reason. I assume that the ability to do this just isn’t enabled?

Any ideas?


#2

If you’re running PHP as a CGI, any PHP directives in .htaccess have no effect. Since I want to run PHP as a CGI for security, I’ve placed most of those directives in conf.php:

ini_set(“magic_quotes_runtime”,“off”);
ini_set(“magic_quotes_sybase”,“off”);
ini_set(“session.cache_expire”,“200000”);
ini_set(“session.cookie_lifetime”,“2000000”);
ini_set(“session.auto_start”,“off”);
ini_set(“session.save_handler”,“user”);
ini_set(“session.cache_limiter”,“none”);