Drupal "register_globals" php error - any suggesti

apps

#1

hello

i got this error on some of my sites … now it is preventing me from installing a new install

i do not want to install a custom php as suggested by tech support because i do not have the skills

any solution will be very appreciated

Error Text:
register_globals is enabled. Drupal requires this configuration directive
to be disabled. Your site may not be secure when register_globals is
enabled. The PHP manual has instructions for how to change configuration
settings.
http://au.php.net/configuration.changes (Currently using PHP register
globals Enabled (‘1’))
<<


#2

If you haven’t customised your php then the register_globals flag is disconcerting.

Could you possibly create an info.php file and report what it says?

<? phpinfo() ?>

Specifically values of “PHP Version”, “Configuration File Path”, and of course “register_globals”.

Maximum Cash Discount on any plan with MAXCASH


#3

thank you for your quick response.

altough i am fluent in drupal and templating etc, i am not fluent with php so your answer does not make sence to me.

I assume i make a doc named “info.php” with “<?
phpinfo()
?>” in it and upload it.

Then the script will out put results somewhere?

any further clarifation would be good and i will follow your steps


#4

You’re exactly right :slight_smile:

Upload it to a browserable (can that be a word now?) directory and load it up in your able browser.

Maximum Cash Discount on any plan with MAXCASH


#5

If Drupal is reporting register_globals is on, and you are not running a customized PHP, this is an indication that your domain is running PHP4 (which you can confirm, of course, with phpinfo() ), so your fix, in this case, is really easy:

Just go to “Domains -> Manage Domains”, and click the “edit” button under the “Web Hosting” column for the domain.

On the next page, use the pull-down selection box to change your PHP to PHP5, and save the settings. That problem will be solved as PHP5 ships, by default, with register_globals = OFF.

Of course, this is a “one way” trip so be careful (more info here)! If you are running any software (osCommerce comes immediately to mind) that requires PHP4, you will only have made matters worse.

–rlparker
–DreamHost Tech Support