Drupal install problems

apps

#1

Hi,
I am having a bit of a time with this drupal install.
Not sure if there is anything special dreamhost needs.
The issue is that I get this
Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/.nape/dg/g.dg.org/drupal-4.6.2/index.php:1) in /home/.nape/dg/g.dg.org/drupal-4.6.2/includes/session.inc on line 10

and I have followed all teh forum threads on drupal about getting rid of e hanging spaces, etc. ANy advice? I only have ftp access on this account, so I wonder if there might be an issue with teh unpacking??
thanks in advance !
jen


#2

Unless you uploaded everything in binary instead of using ascii for text based files then that shouldn’t be a problem…

What are you using to edit the drupal files? If its notepad,wordpad, or something similar I would suggest trying Chrimson Editor, it supports saving unix style files. http://www.crimsoneditor.com/

It is probably from dos style line endings causing problems, just resave any files you edited previously as unix style files and upload them again.

Yes, settings.php has taken the place of conf.php

Hope that helps


#3

(orig. posted to wrong thread…excuseme)

Ok, Drupal is telling me that my “files” folder doesn’t exist. It DOES exist and is set to 755. The odd thing is that the “tmp” directory is in the same location, passes the test, and is set to 755 also.

I read the faq about “suexec” and I think I am set up properly. Should I have run ‘php as cgi’ set?

thanks in advance :slight_smile:
jen


#4

Check the path on the main page of settings and be sure it just says files, no leading or trailing slash. PHP being set as an apache module should be ok.


#5

Check, got that. But still, the directory is not writable, chmod’d to 755. So close I can feel it!


#6

Make it 777


#7

yea! thanks that did it! Both the instructions for drupal and Dreamhost specify 775. Is there any security issue with 777? Thanks again for sharing your knowledge.


#8

Using 777 allows anyone to read/write/delete, but since its just set on the directory and the files dont inherit the permission it should be fine.


#9

Note that setting a directory to 777 will allow anyone to delete and rename files within the directory, as well as create new files. It’s never a good idea to set world write permissions on a shared server.

  • Dallas
  • DreamHost Head Honcho/Founder