Drupal Install on Dreamhost

apps

#1

I’m following the instructions on http://drupal.org/node/260
to install Drupal. I ran into a bit of trouble so I’m doing it again documenting as I go.
After I logged into my dreamhost shell account and
cd to my root of my target website directory, cd example.com
I fetched the file using
]$ wget http://drupal.org/drupal/drupal-4.4.2-2.tgz
and unpacked it using
]$ tar -zxvf drupal-4.4.2.tgz
then according to the instructions I ran

]$ mv drupal-4.4.2/* drupal-4.4.2/.htaccess home/mydreamhostserverusername/example.com

Now the next part, Item 2 on the instructions:
searching the posts I ran the create database from the Dreamhost Webpanel Goodies tab, I also created the unique username, and a mysql hostname.

Does anyone have any Dreamhost specific instructions for items
3 and 4? ( Did I finish item 2? ) Any files I need to edit, password protect, to make Drupal “start”?


#2

So I ran this next:
$ mysql -u myuniqueusername -p dbasename < database/database.mysql

Enter password:

ERROR 2002: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)

And I have a error message that is telling me something.
What does this mean?


#3

msyql -h[your database hostname] -uusername -p databasename < [the file]


#4

That worked, my database has a lot of interesting things displayed when I log into http://mysql.mydomainname.com/

Now I am on step 4 of this process http://drupal.org/node/260
and it is rather confusing.

After I made changes to conf.php I did this:
$ cp conf.php vhost.mysql.mydomainname.com/

But when I visit my website with a browser it gives me this message:
unable to select database.

I’m not done yet.


#5

i’m getting the same error message:

Warning: mysql_connect(): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /home/.caan/ninepage/nine9pages.com/drupal-4.4.2/includes/database.mysql.inc on line 12
Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)

i’ve revised line 12 in the database.mysql.inc file and still getting the error; i’m using interarchy so am not sending commands to the ftp and not sure how to do that. is there a way to alter the actual files in order to fix this?

thanks.


#6

Edit include/conf.php and change the line which defines $db_url to something like “mysql://username:password@mysql.yourdomain.com/databasename”. Make sure you use the SQL user & hostname you set up for that database.

For best results you should unset the option to run PHP as a CGI so you can use the settings in .htaccess.

I’m running two Drupal sites here: macmegasite.com & embarcadero-condo.com, and I’m in the process of getting worldbeatplanet.com (also Drupal based) up here once PEHosting can get me a more recent database backup.

I switched all of my sites here yesterday after PEHosting had a big crash with loss of data following weeks of frequent downtime.


#7

Where do you usnset the option to run PHP as a CGI?

I’m having an issue where although I can connect to my drupal page, nothing happens when I click the Create New Account button. Any ideas?

Thanks,
Kevin