Drupal - 500 Internal Server Error

apps

#1

Suddenly having this problem with my Drupal 5.1 install. Support claims it’s due to the new PHP installs.

Logs say: “Premature end of script headers: php.cgi”

Is anyone having this problem with their Drupal sites on Dreamhost? Any clues about how to solve? My searching is turning up nothing so far here, or at Drupal.org or through Google.

Thanks

CFoxgrover


#2

Hi,

I have just installed Drupal without errors. Perhaps it’s a permission problem.

If you would like me to have a look PM me your URL.

Also perhaps you can also consider submitting a one click install request to DreamHost. I have started a thread to ask people to vote for Drupal to become a one click install, see here: http://discussion.dreamhost.com/showflat.pl?Cat=&Board=curious&Number=80396&page=0&view=collapsed&sb=5&o=14&part=

Joomla Development for Sole Traders to Medium Businesses.
Full DreamHost discount</font color=red> using CELDUFORUM</font color=red>


#3

My site had been running for 6 weeks and then stopped working, according to support because of the upgrade. I’m glad to hear a new install works.

CFoxgrover


#4

No problems with my existing Drupal sites on DH. Maybe something to do with a module your using?


#5

That’s helpful. Thanks. Just one step on a long journey I guess. Since the site was working for weeks with no changes made to the site it’s a mystery I can’t solve. Disturbing… Not sure whether to give up on Drupal or Dreamhost.

CFoxgrover


#6

I’m having some problems with Drupal and both PHP 4 and PHP 5.
I’ve found that (for me) PCRE in PHP 4 is “broken”, that is, the Textile module doesn’t work anymore.
I’ve contacted Dreamhost, but they told me they can’t support 3rd party sw; I’ve tried to contact Drupal maintainers of the Textile module, with no luck for now; I didn’t tried to contact the authors of TextilePHP after seeing that the last bug is from 6 months ago; I’ve found some reports of PHP segfaults due to stack overflow of PCRE, heavily used in Textile. PHP developers say it’s PCRE fault. I don’t know what PCRE authors say…


#7

That must be it or at least that may be it ;). I use the textile module For all my content posts. So maybe the PHP upgrade just pushed it over the edge. But it seems switching to PHP 5 doesn’t help either. I wonder if there is anyway to disable the module in a way I can get into the site and then painstaking fix all that content.

Thanks very much. Very valuable info.

CFoxgrover


#8

Yep that’s it! disable the Textile module directory and the site came right up. Damn! I’m not qualified to fix this and developer hasn’t been on it for two years so who knows if he cares.

CFoxgrover


#9

No warranty. But you could try putting

ini_set(‘pcre.backtrack_limit’, ‘10000’);

at the beginning of index.php, inside the <?php obviously, and then re-enable Textile. It’s probably more complex then that, but for me it worked. Dreamhost is looking at the recent problems with the PHP upgrade, they said, so maybe in a few days there will be a better solution.


#10

Thanks! I’ll give it a try. And hope for an upgrade on the module, or PCRE. What do you think the chances of that are?

Is Dreamhost really looking into problems associated with the PHP upgrades?

Thanks again

CFoxgrover


#11

[quote]No warranty. But you could try putting

ini_set(‘pcre.backtrack_limit’, ‘10000’);

at the beginning of index.php[/quote]
This worked beautifully. Thanks.