Good afternoon,

I know this may have been asked this a million times and I apologise in advance!, but what details do I input into Dreamweaver 8 so I can access my MYSQL database?

Everything is set up correctly previous to my database connectivity; I can access and save to the remote server, everything works 100% fine, but I cannot successfully connect to my MYSQL database which I need to work with.

The details I am putting into Dreamweaver is as follows:

Connection: name
Server: mysqlname.domainname.com
Username: username
Password: pass
Database: mysqlname

I get the following error:

HTTP Error Code 404 File Not Found.
1)There is no testing server running on the server machine.
2)The testing server specified for this site does not map to the http://domain.com/
_mmServerScripts/MMHTTPDB.php URL. Verify that the URL Prefix maps to the root of the

Irrespective of whether I put the correct database name in and test the connection, or try and let Dreamweaver search for the databases that are available on that server, I end up with the same error a few lines above.

Obviously there is an error somewhere, but because everything else successfully works fine, I am completely stuck.

Can anyone help?

Has anyone successfully got this working?

Many thanks

One thing that comes to mind, have you configured the database to allow remote access for your user? I believe you can only connect from ‘%.dreamhost.com’ hosts by default.

To configure a database user for remote access go to Goodies -> Manage MySQL in the panel, click the user you wish to configure then add your host name or IP address to the list.


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]PRICESLASH[/color] ( Click for promo code details )

Hi Raz, yup, all is configured, even in that section of the Dreamhost Control Panel.

I have already contacted a guy at Dreamhost support but he wasn’t clued up on Dreamweaver unfortunately.

The main problem is lying where Dreamweaver assumes that the sql database is in the same location as the webspace, and when it is putting the MMServerScript file(s) at the location, it is not finding the SQL database.


Arh well, I didn’t really expect the solution to be that simple, but I figured it was worth suggesting, just in case.

I do use Dreamweaver here on a semi-regular basis, but I tend to test things by uploading to a test domain I have at DreamHost and running things there, so I don’t have any experience with this part of Dreamweaver. :frowning:

Hopefully, someone with more experience with Dreamweaver will chime in with a suggestion or two.

Good luck Liam.


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]PRICESLASH[/color] ( Click for promo code details )


I just did a quick forum search and the following threads turned up, which seem related to your problem. I am not sure if either has a solution to your problem, but they are probably worth a look.



Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]PRICESLASH[/color] ( Click for promo code details )

Mark, you’re a star.

For anyone reading this with the same problem, it seems that if you change the host directory to /domainname.com instead of just / in the Dreamweaver settings Testing Server section, but also have domainname.com as your FTP host, it successfully connects.

Much appreciated, thanks Mark.


No problem Liam, I am glad you found the problem.

and thanks for posting the eventual fix, I am sure others experiencing the same problem will appreciate it in the future, including me, if I ever get around to changing my testing procedures. :slight_smile:


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]PRICESLASH[/color] ( Click for promo code details )