DreamPress Varnish "Yes, Sort Of" best practice troubleshooting


#1

I’ve been on DreamPress a few months and have never been able to get Varnish working despite submitting a handful of tickets. The most recent ticket said, “memcached corrupt opcache so I turned it off” (from memory, but pretty much gibberish to me).

I use very popular theme with a fairly simple child theme. I’ve tried activating the theme without child and also activating an out-of-the box recent wordpress theme. Overlap this with renaming the plugins folder, and no matter what, still get “Yes Sort of” at isvarnishworking.com including the following items

Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Set-Cookie: PHPSESSID=; path=/

Also tried upgrading php version. Visited isvarnishworking.com in different browsers on Windows and Mac, also clearing browser caches.

FWIW, the site migrated from shared hosting, and there have been some plugins deactivated and deleted for things the standard DreamPress does that could have left artifacts, but I’ve done my best to verify scrub using documentation from the plugin developers. Aim to fix the Varnish issue via pure DreamPress standard and then tread carefully going forward and check Varnish regularly. I.e. it didn’t work when it migrated to DreamPress, and we’ve never been able to fix it.

Totally stumped, but this is all pretty new to me, so I could be missing a step or taking a step I shouldn’t. Troubleshooting advice googled seems to lean toward the varnish vlc or backend setup, way over my head or inaccessible or both or the troubleshooting items I’ve tried above. As far as I can read the error logs, it’s pretty much Premature end of script headers: index.php, though the errors seem to have decreased after the support ticket about opcache.

test.dbdt.com Want to get Varnish working properly, but would like to understand more about it and my site in the process.

Thanks in advance.