DreamObjects file permissions with Cyberduck

dreamobjects

#1

I have configured the Cyberduck software to connect to my DreamObjects account using the document you provided. However I noticed that when I upload files with the Cyberduck software with the preferences set to not change permissions on the files, the permissions they get when viewed through the DreamObjects object viewer shows them to be set to “Private”.

I would like for the files to be uploaded as Public, but is that even possible using the Cyberduck software? It allows you to change the permissions on upload, but whenever I tried to it always displayed as “Custom” in the object viewer. Is there a particular combination of Owner/Group/Other settings to mark it as “Public” instead of “Custom”?


#2

You can update the permissions for uploads in Preferences > Transfers > Permissions

To set the permissions to public on uploaded files, change the settings so that the “Others” group has the “Read” checkbox selected as well as the “Owner” group having “Read” and “Write” checkboxes selected.

Here’s a screen shot: http://wiki.dreamhost.com/images/4/45/Cyberduck_permissions.png


#3

Thanks, that’s exactly what I was looking for.