Dreamhost shut down my WordPress

apps

#1

I got the following message from DreamHost support:


I’ve temporarily disabled your database because you are running a query that is hitting the database too hard.

Please prevent the following query from running:

SELECT alas_posts.*, MAX(comment_date) AS max_comment_date FROM
alas_comments, alas_posts WHERE alas_posts.post_date <= ‘2005-07-19
13:38:31’ AND ( alas_posts.post_status = ‘publish’ OR
alas_posts.post_status = ‘sticky’ ) AND alas_posts.post_password = ‘’ AND
alas_posts.ID = alas_comments.comment_post_ID AND
alas_comments.comment_approved = ‘1’ GROUP BY alas_posts.ID ORDER BY
max_comment_date DESC LIMIT 0, 20;

Once you have done that, please contact support, informing them that you have disabled that query, and they will reenable your database. Please refer them to this message.


Here’s the problem: I haven’t the slightest clue what they’re talking about or how to shut a particular query off. If I’ve been runing that query, I haven’t been doing it on purpose.

Clearly, Dreamhost doesn’t like something about my WordPress blog, but I don’t understand what to change, or even how I can change anything when they’ve shut off my access to WordPress completely.

If anyone has encountered this problem before or has suggestions, I’d really appreciate advice. Thanks!


#2

Without visiting your WordPress blog and looking at it, I wouldn’t know where to start to fix it either…and we can’t do that with it “down”. Have you tried posing the contents of the support message to the WordPress support forums at
http://wordpress.org/support/ ?

–rlparker


#3

You might also reply to support and ask for further clarification and help - they should be pretty accomidating. Expecially seeing as it’s a onc click install.

-Matttail


#4

The query appears to be fetching comments. Don’t know a thing about WP, but it sorta looks like if you turned off comments you might be able to get it turned back on long enough to troubleshoot and tinker a bit.


#5

Hi! I’m the original poster - sorry about the anonymous first post.

The problem appears to be caused by my “recently commented posts” plugin. I’ve uninstalled the plugin for now, and I’m researching ways to have such a list without undue strain on the server load.