Dreamhost Private Server - Max CPU Limit Exceeded


#1

I recently upgraded to Dreamhost PS and since them my site is down with the following errors:

[Tue Jun 10 20:49:23 2008] [error] [client 67.195.58.185] Premature end of script headers: php5.cgi
[Tue Jun 10 20:48:59 2008] [error] [client 71.166.94.119] (12)Cannot allocate memory: couldn’t spawn child process: /dh/cgi-system/php5.cgi
[Tue Jun 10 20:48:59 2008] [error] [client 71.166.94.119] (12)Cannot allocate memory: couldn’t create child process: 12: php5.cgi

I am on WordPress and have upped the limit to 2300 MHz of CPU time but the issue is not resolved.

Dreamhost says that there’s a script that utilizing all the memory but I am just running that latest version of WordPress with no plugins.


#2

It is about the memory but not the CPU.

You can try to run top command to see what process has taken up so much memory.

$50 off and 3 free domains with code: [color=#CC0000]DH3[/color] Sign Up NOW or More Codes Here


#3

When I run the top command, I see tons of php5.cgi processes in addition to apache httpd processes.

I am running the latest version of WordPress with no processes and am not sure what’s causing this issue.

Thanks for looking into it.


#4

I’d guess that your site is getting a lot of traffic. Is this expected? If not, you might consider looking to see if it’s some kind of crawler that’s causing you trouble. What was the situation before you got switched over to PS? Was your site slow? Were you using too much resource for a shared hosting account?

Are you running a lot of plugins in your WordPress installation?

Use the [color=#CC0000]3DOM50[/color] promo code for 3 extra lifetime domains and $50 off
More Dreamhost coupons here!


#5

I have disabled all WordPress plugins.

Things were pretty normal before I switched to PS.

All the memory is taking my php5.cgi processes and hence the site is down though I am not experience any great traffic at the moment.

When I reboot the server, things get normal for few seconds and then php5.cgi processes consume all the memory bringing the site down.

The support sent me this mail - “You may want to consult your statistics to help determine where the most activity is.” I am not sure how to proceed now since I know its the php5.cgi processes that’s taking the site down.


#6

It is hard to tell the problem :frowning: But definitely something is wrong with php script. It could be a infinite loop or too many connections.

Is it better after you disabled all plugins? If so, it means it is the problem of the plugins. To find out which one, you can try to turn them on one by one.

Does error log complain anything?

$50 off and 3 free domains with code: [color=#CC0000]DH3[/color] Sign Up NOW or More Codes Here


#7

You need some plugin that make cache, like wp-cache, wordpress is well know for generate each page as is asked, so it uses a lot of memory and cpu, if you had a lot of visitors you need at least a plugin to cache your content or think on static content.

Regards.


Somewhere, something incredible is waiting to be known.
Sagan


#8

As usual, support is giving you the best advice. (Not saying that they’re always right, but that they’re a pretty competent group as a whole)

Do you have any idea about how to view and interpret the statistics on your web traffic? If you are a beginner at it, you should start from the wiki article:
http://wiki.dreamhost.com/KB_/Account_Control_Panel/Status::_Statistics

Use the [color=#CC0000]3DOM50[/color] promo code for 3 extra lifetime domains and $50 off
More Dreamhost coupons here!


#9

That’s a great point, and an important part of improving the performance of almost any WordPress site!

While wp-cache is indeed better than no caching at all, I recommend WP-Super-Cache. I think it does a better job in most circumstances. :wink:

–rlparker
–DreamHost Tech Support