Dreamhost limits connections to 20 per IP!?


#1

What on earth is going on here guys? Over the past few days I’ve noticed some images on my site not loading. I emailed Dreamhost and they got back to me, saying:

“It looks like your site is trying to make quite a few simultaneous
connections at once, and exceeding the concurrent connection limit:
reason: Client
exceeded concurrent connection limit of 20, referer”

Something must be wrong here, because I’ve never had the error before, and I haven’t changed anything on my pages in quite a while. Im getting broken images everywhere.

Anyone else having issues with this?


#2

I have not had that problem, but I can confirm that DH does limit the number of concurrent connection from a given referrer.

Have you looked at your logs to see if someone is DOSsing you by hammering your site that hard and that repeatedly?

Were you linked by some powerhouse website that is pointing everyone to you?

Is some other site, hotlinking one of your images?

What is the url of you site?

–rlparker


#3

20 concurrent connections from a single client is kinda high. Isn’t the IE default 4 and the Firefox default 8?

I know some tuning guides will have you set your browser up to a pretty high value like 30 or so, but I hear a lot of folks setting their apaches to limit the concurrent connections from a single referrer in order to keep your site from being hammered by some not-so-distributed DoS attacks or being hammered by bots.

Use the [color=#CC0000]3DOM50[/color] promo code for 3 extra lifetime domains and $50 off
More Dreamhost coupons here!


#4

Thanks for the heads up guys, I went ahead and disabled some hotlinking dir’s which people were hitting, but seen no obvious signs of DDOS. I did notice that somehow firefox had changed the default connections to 22, so thats what was probably doing it. Sorry for the confusion, but thanks for the help guys!


#5

Do you by any chance use the Faster Fox extension?

I recently had a bunch of different sites that were really dragging their feet and seemed to load faster in IE (there’s a sure sign that something is wrong :stuck_out_tongue: ). I think something changed with a recent Faster Fox update, but knocking the setting down from Turbo Charged to Optimized made things run much smoother.


:stuck_out_tongue: Maximum savings promo code: MaxSavingsAtDH