Dreamhost jabber can't communicate with googletalk


#1

One of my jabber accounts stopped being able to communicate with google talk users recently. Authorisations/statuses/messages stopped coming through. Meanwhile my other accounts were fine. Tech support meddled with the config and ended up breaking my other accounts: now I cannot communicate with google talk users from any of my jabber accounts. Tech support claim it’s not their problem but a) only one of my accounts was broken until tech support tried to fix it, at which point all my accounts stopped working, b) apparently not all servers (I’m on grand) have this problem - otherwise there would have been an uproar. I can only conclude that there is something wrong with the jabber set up on grand which needs to be fixed. I have jabbered without a glitch for a long time - it’s not good enough to say I should just accept that I cannot communicate with all my contacts on google talk henceforth.

Leaving aside the fact that I shouldn’t have to do anything extraordinary for my jabber accounts to work properly, I have read and followed the advice on http://wiki.dreamhost.com/Jabber_SRV_records , but it has not fixed the problem. At the end of that wiki page it says “If it doesn’t work, you have to go at your Google Apps account of your domain (eg. http://google.com/a/yourdomain.com) and disable Google Talk service, otherwise google server will try to use own server to delivery messages and you won’t be able to receive incomming messages from any of your Gmail/Gtalk contacts.” Does anyone know how I can log in to this google apps account that I never asked for!? What username and password should I use (my DH account details do not work).

Thanks.


#2

I, too, am still experiencing this… I have Jabber accounts on two different Dreamhost-hosted domains and for whatever reason this problem only affects one of them.


#3

Could you tell us what server is affected? Is it “grand” by any chance? If we can pinpoint which ones work and which ones don’t, then perhaps DH can try to pinpoint what the differences causing the problem are and - at worst - move customers who complain to a server that works…


#4

I also have the same problem: authorizations are not making it through from Google Talk to my DH-hosted Jabber account.

I am not using Google Apps for Domains, and I too was told by support that if setting up the SRV records don’t fix it it’s not their problem.

I don’t know which server is hosting my Jabber account, but here’s what I’m on:
File Servers: dunker
Your Web Server: delorean
Your Email Server: frisky
Your MySQL Server: nicodemus


#5

Anybody? No?


#6

I can’t let this one die.

I too have been having the authentication problem. I have tried authentication with other non DreamHost hosted Jabber accounts and they work fine.

I’m on dribbler, thanatos, janky and roderunner for file, web, email and SQL respectively.

I have send support an email about this as well.


#7

Same problem here and I’m on web server Ikari.


#8

For the record, I had to email Google and ask them to remove my domains completely from Google Apps. I have no idea who added them. It wasn’t me so, in theory, it could only have been Dreamhost (but they deny this). Anyway, once you’ve removed your domains from Google Apps, your Jabber accounts work fine once again.


#9

That solution won’t work me since my domain isn’t in Google Apps.


#10

Is there a way to check if the domain was added to Google Apps? I don’t have a login/pw for the Google Apps page for my account, that’s the only way I can think of.

Update:

Nevermind, I checked my domains via Google Apps by trying to “add” them, kept getting this:

“This domain has already been registered with Google Apps. Please contact your domain administrator for instructions on using Google Apps with this domain.”

It certainly wasn’t me that added them to Google and these domains are all with DreamHost… what the heck? I sure hope DreamHost isn’t adding everybody’s domain to Google Apps. Now I need to contact Google, if I can find the correct email address or phone or website to do it.


#11

Yes you can also check by going to https://www.google.com/a/domainname and seeing if you get a server error. I agree that it’s ridiculous to have to go through the tedious process of contacting Google, etc for something you didn’t do. Either Google or Dreamhost have added these domains, and neither have admitted responsibility for it. Very sad.


#12

I’ve had a domain added to Google without my knowledge in the past. I only became aware of it when trying to add it myself and receiving an error. The domain wasn’t hosted at DreamHost and chances are that Google didn’t try to add it by themselves. My guess was that someone else had attempted to add it for reasons known only to themselves.

I’m unsure if Google have changed the way you register with Apps now, but it was a case that anyone could enter any domain and start the ball rolling. Even if there was no reply to the email sent to the purported admin of the domain, the domain remained in their system.

As the glitch described in this thread concerns Google Talk I’d suggest they probably haven’t changed the process, leaving this type of hijacking openly available to all and sundry.

Maximum Cash Discount on any plan with MAXCASH


#13

I emailed Google about removing my domains, after a few emails exchanged (the first couple were generic “how to” delete your Google Apps account), they went ahead and removed my domains from their Google Apps verification system. Now my jabber accounts are working perfectly with Google users again.

Now this problem occurred with all 11 of my domains hosted at Dreamhost (with Dreamhost being a registrar/host for some and only a host for others). A couple of the domains were literally added to Dreamhost’s server 2 weeks ago. These are unique domain names that nobody even knew existed so I doubt that any regular “stranger” on the Internet added them to Google Apps verification system.

After conversing with Google (and not mentioning that my domains are at Dreamhost), they responded with this:
“We have removed all the Google Apps accounts for the domains that you specified in an earlier email. Please note that these accounts were not provisioned by us, but rather dreamhost.com.”

Dreamhost support has no idea why this happens and can’t fix it on their end. But from what I’ve gathered (from the timing of the domain registration/host, others having this problem, and Google mentioning Dreamhost), it looks like the problem does lie on Dreamhost’s end. Here’s hoping they figure out the problem soon.


#14

I think they may have done just that by reverting the default behaviour in Add Domain - which was for Gmail to handle domain email. The default behaviour now is standard DH email. It’s easy to see that people happily clicking away without paying attention would have got caught with that, and it certainly wasn’t a good idea on DreamHost’s part to have that Gmail box checked by default.

Maximum Cash Discount on any plan with MAXCASH


#15

I doubt that’ll fix the problem. I’m pretty careful about adding domains since I use custom MX records on some domains, plus most of my domains were added to Dreamhost before they had auto Gmail config during domain additions.

The problem probably lies somewhere else.