Dreamhost Causing Int. Server Error 500 in Joomla?

apps

#1

I’m getting an Internal Server Error 500 in my Joomla administration panel.

All the forums I have searched for fixes suggest the webhost causes this problem.

Anyone have any ideas of what to do?


#2

[quote]
I’m getting an Internal Server Error 500 in my Joomla administration panel.[/quote]
Any number of problems, from the sublimly trivial to the “deep and dark” can cause this error. Have you looked at your server error logs for hints? It is usually something very simple to fix, especially with a mature product like Joomla.

I don’t even know how to respond to that…er, yep…it is the webserver that is experiencing the error, though that is a far cry from saying the “webhost causes this problem”. The reality is that the code caused the problem for the webserver :wink:

My guess would be that probably a lot of people could give you some suggestions if they had the barest of information.

First of all, I suggest you take a look at how to ask smart questions and then get back to us with a little more info so we can help you:

  1. What version of Joomla?
  2. Dreamhost “One-Click”, or did you do it yourself?
  3. PHP4? PHP5? PHP as CGI? (possibly answered by #2 above)
  4. Does Joomla run at all? Can you load the “administrator” back-end at all, or does it crash when you try to do a certain thing?
  5. How are your permissions set on the Joomla Directories (again, possibly answered in #2 above)
  6. and , my favorite, what is the output of phpinfo? (just search these forums for further on how to generate that if it is new to you.)
  7. The url of your site?

I strongly suspect that, with a little more information, those here can get you running in no time. Joomla is pretty solid, and I have lots of Joomla’s installed around various Dreamhost servers.

Do a little specific research and post again; we can probably help.

–rlparker


#3

Thanks for the fast reply. First off, I would like to apologize for not including information about my Joomla configuration. I wasn’t really looking for help with it (I was looking for help with Server 500 errors in general), but since you replied, I think I could use your help. Thanks a lot for replying!

The Internal Server Error 500 itself is occuring in the Joomla backend when I try to save content or login at the website.

I just started getting this error today. I’m using Joomla 1.08 (installed using 1 click install) and my website has been running fine since I first installed Joomla (which was around a month ago).

Answers to Your Questions

  1. 1.08
  2. One-Click
  3. PHP4 as CGI. I have tried switching to PHP5 but it doesn’t solve the problem.
  4. The only thing that is not working is logging in and saving content in the administration backend. Everything else works.
  5. 755
  6. PHP Info, straight from Joomla:
    http://pcfastlane.com/phpinfo.txt
  7. www.pcfastlane.com

I don’t know if this could be causing anything, but an article on my website made the homepage of Digg and Shoutwire. It’s been surviving the traffic fairly well. Right now I have 159 visitors on my website (according to Joomla), though that isn’t too much.

I looked through my error log and these are the only errors I’ve been getting related to Administration.

[Wed Apr 19 05:26:59 2006] [error] [client 68.185.xxxxx] File does not exist: /home/sleepysentry/pcfastlane/favicon.ico
[Wed Apr 19 05:26:59 2006] [error] [client 68.185.xxxxx] File does not exist: /home/sleepysentry/pcfastlane/missing.html
[Wed Apr 19 05:27:00 2006] [error] [client 68.185.xxxxx] File does not exist: /home/sleepysentry/pcfastlane/joomla/administrator/templates/joomla_admin_black/images/version.png
[Wed Apr 19 05:27:00 2006] [error] [client 68.185.xxxxx] File does not exist: /home/sleepysentry/pcfastlane/missing.html

Thanks for being so patient!


#4

Now there is a question, and several potential starting points. Thanks for taking the time to put that post together, it really helps me start to have an idea where to look.

The first thing that comes to mind as DH’s “different” way of managing permission (suexec in place). While 775 should work for permissions, it has been my experience that DH doesn’t like it, and I would check that first. Try 755 - it should be (has been for me) all you need for the “cgi user” (you!) to do what ever is needed by joomla, and I strongly suspect that DH might be interfering with writing to directories that are set to 755 when you try to save content/other back-end function that attempts a “not so obvious” write.

If you are still close by, why don’t you try a quick resetting of all your 775 permission to 755 (it will not “break” the site, at least not more than it already is :wink: and see if that resolves the problem.

Meanwhile, I’go take a look at a couple of other things possibly related and I’ll get right back to you.

Regards,
–rlparker


#5

I just realized I made a typo in my original post. My permissions were set to 755, not 775. I edited my original post to reflect this change.

I set my administrator permissions to 775 just for the heck of it. Unfortuately, it didn’t work.

Let me know how your research turns out.

Thanks for being do dedicated.


#6

Well, by the numbers:

I took a good look at phpinfo, and everything looks “normal” there, I know of no “borkedness” in 1.08 that could account for your problem, one-click is pretty simple, php4 /CGI is the easiest configuration to get working correctly, I mentioned the “anecdotal” possibility of 755 permissions maybe working better than the 775 (which, by the way, in my latest Joomla installations is only set on the cache directory), and the site works well.

(I loved your Great gmail adventure…you should have gotten something for your efforts!)

It is especially puzzling since the site was working fine until today. One would think that something had to have changed for it to go “paws up”. I’m wondering if there could be any relation to the “rumored” mySql updates taking place on some servers today (see the thread about phpMyAdmin on this forum).

Nothing in the error logs looks relevant.

I’m a little confused though. If you can’t log-in, how can you get to the back-end to have it crash when you try to save content? Or can you “log in” as administrator, but can’t login to the front end as a user?

You have not made any config changes, like turning on SEF urls or modifying your .htaccess, have you?

I’m keeping on looking…
–rlparker


#7

No problem :slight_smile: We have all had keyboard problems! I’m sorry I haven’t provided much useful input toward fixing your problem.

I registered on your site, activated from the welcome email, and tried to login, but the browser just “churned away”…no love there.

A quick look over at the Joomla forums and a search for “login 1.08” shows you are not alone on that count…several different problems and suggestion there. It looks like 1.08 might have been rush out the door before it was completely ready.

There is some other strange stuff going on with 1.08 also, and rather than me “relaying” if you find the time, you might want to cruise those thread at the joomla.org forums.

For the life of me, I can’t figure out what would cause an Internal Server Error 500 other than some misconfiguration of the server, or the cgi code running under it, and too much of your site “works” for it to be something “unsubtle”.

I’ll think on it a bit, and check a few more things as they come to mind and see if maybe we can figure this out.

I’m not that “dedicated”; I’m just a “heavy” joomla user and I know whatever broke for you will break for me too, so it is in all of our best interest with opensource stuff to work together to nail down the gremlins ;-).

-rlparker


#8

I am able to login to the administration backend but not on the frontend of the website as a user.

I haven’t made any config changes at all.

Thanks for your help and let me know if you find something else.

I’m glad you liked my article :). I still haven’t heard back from the Gmail team yet :(.

I’ll go do some cruising around in the Joomla forums!


#9

UPDATE- Source of Error Found

It seems turning content caching on is causing this problem. When I turn it off, the problem is fixed!

It looks like I now have a temporary fix for my problem. However, I need content caching, otherwise it will be obliverated by the Digg effect! Remember, users cannot login on the front end when I have content caching turned on.


#10

Aha! I see…now I’m wondering if the 775 permissions on the cache directory might be the source of that error, as in when caching is “on” Joomla tries to write to the cache directory, DH doesn’t like the “775”, and throws the Internal Server Error, but when caching is “off” no write attempts are made, so no problem is noticed.

On my "“one-click” installs, the cache dir was the only one set at 775, all the rest were set to 755 (I discovered this yesterday when we were investigating). Have you considered changing the cache dir to 755 and trying again? I’m thinking that just might let you use the cache and eliminate the problem at DH.

–rlparker


#11

My cache directory seems to be set to 755 already.

Strangely, I cannot access it with my FTP client! When I try to browse the cache folder, the FTP client tries to open it but never does, and I end up with a message saying, “Server closed connection.”

Could it be this folder was taking up too many server resources due to my influx of traffic and Dreamhost is trying to stop me from putting anything there?

Do you think I should contact Dreamhost support now? This seems to be on their side of the hill now.

Right now I’m turning extra web security off on my domain to see if that does anything.

Thanks for the help!


#12

No luck :(.

What should I do now? Contact Dreamhost?


#13

Sorry to hear that you got “no love” with the change in the “extra web security” setting, and obvously the 775/755 thing is not relevant.

It sure couldn’t hurt to give DH Support a shot, though I’m not sure they are gonna be of much help with the “3rd party script”. They should, I think, be able to shed some light on why you cant access the cache dir with ftp. That is strange. I assume you confirmed that you own the directory, and I can’t figure out whay it won’t let you in.

It may also be true that the heavy load from digg triggered something on the DH side, so a support contact can’t hurt.

As for the “thanks”, you are welcome, though I haven’t been of much real help (though I suppose it never hurts to have someone to commiserate with and bounce ideas off of).

Good Luck, and keep me posted; I’ll post back if I have any “revelations”.

–rlparker


#14

Dreamhost customer support has told me the reason why I can’t access it is because there is so much data in it (16 MB).

Does this sound like something that could be true or bs to you?


#15

Well, I suppose anything is possible, but that does not sound right to me. I mean, 16 MB is not that much data.

Now, if the 16MB is a whole lot of very small files, that might make some sense, but I’d sure want a better explanation than that. I mean, it has to be something other than the fact that there is 16 MB of data, as that is less than 3 files of the 7MB php upload size limit… 1 short video clip, a couple of reasonable sized tarballs, 2 MP3s, etc…nah, I wouldn’t buy that is the amount of data if it is only 16 MB. If the 16 MB is made up of 1-5 kb files, then maybe the server is balking at building the ascii “ls” list to display the directory over ftp, but I have no direct experience with that.

I’d write back and ask for a little more thorough explanation.

–rlparker