DreamCompute: Instance failing, RAM exceeded > Resized > Image deactivated

dreamcompute

#1

I’m experiencing a major issue with my DreamCompute instance.

RAM was exceeded (I believe an analytics script saving lots of data to the DB was the culprit), so I resized/upgraded. My app was still working but obviously no database connections could be made, since MySQL was automatically turned off. The resize worked fine, but then, the entire server became inaccessible.

I dug around in the Compute admin area and can see that the image my instance is using (Ubuntu 18.04) has been deactivated. There is another Ubuntu 18.04 that is active. Why would this happen? How do I get it back?

I have submitted a ticket to support, but it’s been almost 24hrs with no response. I realize for everyone else that is a short amount of time, but for me and my users, that’s excruciating!


#2

I have to speculate without further details, but if your DreamCompute instance was saving lots of data to the DB, maybe you just ran out of space. If that’s the case, you’d need to increase the storage available on the instance by increasing the storage either by attaching a volume (if an ephemeral instance) or increasing the size of the attached volume (if booted from a volume). You’ll then have to log into the machine and make the appropriate changes in the OS so that it’s aware of the larger volume.

As for the Ubuntu image being deactivated, that is standard process as we upload more recent versions of the operating systems. This helps reduce the amount of updates you would need to do when you start a new instance. It has no effect on an existing instance booted from a previous version.


#3

So I did resize the instance. That worked fine, confirmed in the UI.

But after doing that, nothing is working at all. I am not sure what to do now, in order to get everything up and running again.


#4

Resizing the instance only changes the amount of CPU and memory for the instance, it doesn’t change anything storage-wise.

Are you able to ping the machine? Can you SSH into it? Maybe the machine is running but the services aren’t.


#5

I can SSH into it yes.

In the log, I see the following:

[   12.669014] cloud-init[903]: OSError: [Errno 28] No space left on device
[[0;1;31mFAILED[0m] Failed to start Execute cloud user/final scripts.
See 'systemctl status cloud-final.service' for details.
[[0;32m  OK  [0m] Reached target Cloud-init target.
[[0;1;31mFAILED[0m] Failed to start MySQL Community Server.
See 'systemctl status mysql.service' for details.