Dream Compute libs to VPS?

dreamcompute

#1

I need to run a 32-bit app. It used to work before the upgrade to Ubuntu 14.04. like this:
LD_LIBRARY_PATH=/home/myname/lib ./my32bitapp
Solution by Justin on 5.17.2016:

The needed libraries from the packages “libc6:i386 libncurses5:i386 libstdc++5:i386” were copied to /home/myname/lib directory.

A symlink was created: ln -sf /lib/ld-2.15.so /home/myname/lib/ld-linux.so.2

Now after the upgrade to Ubuntu 14.04, it doesn’t work anymore.

I created a DreamCompute instance with Ubuntu 14.04, then I installed 32-bit support:

sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo apt-get install libstdc++5:i386

So my 32-bit app works again there. But I need to run it on my VPS.

I copied the libraries needed by my app (according to: ldd ./my32bitapp) to /home/myname/lib and tried to run it: LD_LIBRARY_PATH=/home/myname/lib ./my32bitapp Unfortunately, it still doesn’t work.

Is it possible to use libraries from Dream Compute instance copied to VPS?


#2

The only way to be sure is to try and see if/how this sort of ‘surgery’ fails. Unfortunately I can’t give you a better answer.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.