dotProject

apps

#1

Hello,

I set up dotProject (dotproject.net) at a domain of mine some time ago, and it’s working well except that I was getting a lot of open_basedir errors. I decided to just try to comment out/remove the offending lines, and that seemed to work fine. The problem came when someone tried to upload a file - when you would also get this error, and as it turned out, the offending line was using move_uploaded_file - which is the function which moves the uploaded file to where it should be.

I’ve double-checked the path in the configuration and that the path is the correct one in the scripts as well. It says /home/c28/admin.28chapters.org/dotproject/[…some more] and phpinfo() says that open_basedir allowed folders is this:
/dh/web/phpmyadmin:/tmp:/dh/solidclient:/usr/local/lib/php:/home/c28:/home/.xenophondryer/c28

In other words: It should work, but it doesn’t. I haven’t sent this to tech support as I thought it may be a problem that I have made somehow…

Anyone got any idea on how to fix this?

Thanks in advance,
Eivind Lie Nitter


#2

Posted a little too quick there…

I changed the path in the configuration to include .xenophondryer and now it works.

It shouldn’t be like this, though… or is it the way it has to be?


#3

in the base directory that the project app’s running in, put an .htaccess file with this line in it:

AddType php-cgi .php

see if that doesn’t fix your wagon:

https://panel.dreamhost.com/kbase/index.cgi?area=2526

[color=#0000CC]jason[/color]